summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.8.0-r1.ebuild')
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.8.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.8.0-r1.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.8.0-r1.ebuild
new file mode 100644
index 000000000000..6a38e56e4d3c
--- /dev/null
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.8.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.8.0-r1.ebuild,v 1.1 2013/05/12 10:03:44 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.31:2
+ introspection? ( >=dev-libs/gobject-introspection-1.31.0 )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Don't migrate metacity theme for consistency with the rest of
+ # Gnome 3 theming (as other themes are not migrated), upstream bug #700154
+ epatch "${FILESDIR}/${PN}-3.8.0-metacity-theme.patch"
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS HACKING NEWS README"
+ gnome2_src_configure $(use_enable introspection)
+}