summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/evolution-exchange/evolution-exchange-2.32.1.ebuild')
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-2.32.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-2.32.1.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-2.32.1.ebuild
new file mode 100644
index 000000000000..c8702cf4213e
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-2.32.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-2.32.1.ebuild,v 1.1 2010/11/16 20:34:13 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://projects.gnome.org/evolution/"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc static"
+
+RDEPEND="
+ >=mail-client/evolution-${PV}:2.0
+ >=gnome-extra/evolution-data-server-${PV}[ldap,kerberos]
+ >=dev-libs/glib-2.16:2
+ >=x11-libs/gtk+-2.20:2
+ >=gnome-base/gconf-2
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ >=net-nds/openldap-2.1.30-r2
+ virtual/krb5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-krb5=/usr
+ --with-openldap
+ --disable-static
+ --disable-maintainer-mode
+ --disable-gtk3
+ $(use_enable debug e2k-debug)
+ $(use_with static static-ldap)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/^\(AM_CPPFLAGS="\)$WARNING_FLAGS/\1/' \
+ -i configure.ac configure || die "sed 1 failed"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die "la files removal failed"
+}