summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gal/gal-0.8.ebuild')
-rw-r--r--gnome-extra/gal/gal-0.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gal/gal-0.8.ebuild b/gnome-extra/gal/gal-0.8.ebuild
new file mode 100644
index 000000000000..841dbe09f671
--- /dev/null
+++ b/gnome-extra/gal/gal-0.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# Updated by Sebastian Werner <sebastian@werner-productions.de>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The Gnome Application Libraries"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=gnome-base/gnome-vfs-1.0.1
+ >=gnome-base/libglade-0.16
+ >=gnome-base/libunicode-0.4
+ >=gnome-base/gnome-print-0.29"
+
+RDEPEND="virtual/glibc"
+
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
+ try make
+}
+
+src_install() {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+
+}
+
+
+
+
+