summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/mc/mc-4.5.54.ebuild')
-rw-r--r--gnome-extra/mc/mc-4.5.54.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/gnome-extra/mc/mc-4.5.54.ebuild b/gnome-extra/mc/mc-4.5.54.ebuild
new file mode 100644
index 000000000000..fefdb5d3476e
--- /dev/null
+++ b/gnome-extra/mc/mc-4.5.54.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/mc/mc-4.5.54.ebuild,v 1.1 2001/06/04 06:41:14 achim Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Midnight Commander"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/mc/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/gpm-1.19.3
+ pam? ( >=sys-libs/pam-0.72 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ >=sys-apps/e2fsprogs-1.19
+ gnome? ( >=gnome-base/gnome-libs-1.2.4 )
+
+"
+RDEPEND="virtual/x11-web-browser"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/vfs
+ cp smbfs.c smbfs.c.orig
+ sed -e "s:/etc/smb\.conf:/etc/smb/smb\.conf:" smbfs.c.orig > smbfs.c
+}
+
+src_compile() {
+ local myconf
+ if [ "`use pam`" ] ; then
+ myconf="--with-pam"
+ else
+ myconf="--without-pam"
+ fi
+ if [ "`use slang`" ] ; then
+ myconf="$myconf --with-slang"
+ else
+ myconf="$myconf --with-included-slang"
+ fi
+ if [ "`use gnome`" ] ; then
+ myconf="$myconf --with-gnome --prefix=/opt/gnome"
+ else
+ myconf="$myconf --without-gnome --prefix=/usr"
+ fi
+ LDFLAGS="-lcrypt -lncurses" try ./configure --host=${CHOST} \
+ --with-samba --with-vfs --with-netrc $myconf
+ try make
+}
+
+src_install() {
+
+ if [ "`use gnome`" ] ; then
+ try make prefix=${D}/opt/gnome install
+ else
+ try make prefix=${D}/usr install
+ fi
+
+ dodoc ABOUT-NLS COPYING* FAQ INSTALL* NEWS
+ dodoc README*
+}
+
+
+
+
+
+