summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/krunner/krunner-4.8.4.ebuild')
-rw-r--r--kde-base/krunner/krunner-4.8.4.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/kde-base/krunner/krunner-4.8.4.ebuild b/kde-base/krunner/krunner-4.8.4.ebuild
new file mode 100644
index 000000000000..1f88dd58952b
--- /dev/null
+++ b/kde-base/krunner/krunner-4.8.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/krunner/krunner-4.8.4.ebuild,v 1.1 2012/06/21 21:54:44 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE Command Runner"
+IUSE="debug"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kcheckpass)
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep ksmserver)
+ $(add_kdebase_dep ksysguard)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep libplasmagenericshell)
+ !aqua? (
+ x11-libs/libXcursor
+ x11-libs/libXScrnSaver
+ )
+"
+DEPEND="${COMMONDEPEND}
+ !aqua? (
+ x11-libs/libXcursor
+ x11-proto/scrnsaverproto
+ )
+"
+RDEPEND="${COMMONDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}"-4.6.2-noxf86misc.patch )
+
+KMEXTRACTONLY="
+ libs/kdm/
+ libs/kephal/
+ libs/ksysguard/
+ libs/kworkspace/
+ libs/plasmagenericshell/
+ kcheckpass/
+ ksmserver/org.kde.KSMServerInterface.xml
+ ksysguard/
+ plasma/screensaver/shell/org.kde.plasma-overlay.App.xml
+"
+
+KMLOADLIBS="libkworkspace"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}