summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kio-upnp-ms')
-rw-r--r--kde-misc/kio-upnp-ms/ChangeLog8
-rw-r--r--kde-misc/kio-upnp-ms/files/FindHUpnp.cmake6
-rw-r--r--kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110110.ebuild27
-rw-r--r--kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110313.ebuild18
4 files changed, 21 insertions, 38 deletions
diff --git a/kde-misc/kio-upnp-ms/ChangeLog b/kde-misc/kio-upnp-ms/ChangeLog
index 8c6aa15ee9f7..37b6f26bec3e 100644
--- a/kde-misc/kio-upnp-ms/ChangeLog
+++ b/kde-misc/kio-upnp-ms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/kio-upnp-ms
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-upnp-ms/ChangeLog,v 1.4 2011/04/28 19:36:00 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-upnp-ms/ChangeLog,v 1.5 2011/04/28 20:27:08 scarabeus Exp $
+
+ 28 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ -kio-upnp-ms-0.8.0_p20110110.ebuild, kio-upnp-ms-0.8.0_p20110313.ebuild,
+ files/FindHUpnp.cmake:
+ Operate with the Finders properly. Update the Finder to actualy find the
+ library.
28 Apr 2011; Christoph Junghans <ottxor@gentoo.org>
kio-upnp-ms-0.8.0_p20110110.ebuild, kio-upnp-ms-0.8.0_p20110313.ebuild:
diff --git a/kde-misc/kio-upnp-ms/files/FindHUpnp.cmake b/kde-misc/kio-upnp-ms/files/FindHUpnp.cmake
index 9c7bf7c26626..f9a3779c0fd8 100644
--- a/kde-misc/kio-upnp-ms/files/FindHUpnp.cmake
+++ b/kde-misc/kio-upnp-ms/files/FindHUpnp.cmake
@@ -6,7 +6,11 @@
# HUPNP_LIBS
# HUPNP_FOUND
-find_path(HUPNP_INCLUDE_DIR HUpnp HINTS ${KDE4_INCLUDE_DIR})
+find_path(HUPNP_INCLUDE_DIR
+ HUpnp HINTS
+ ${KDE4_INCLUDE_DIR}
+ /usr/include/HUpnpCore/
+)
find_library(HUPNP_LIBS HUpnp PATHS ${KDE4_LIB_DIR})
diff --git a/kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110110.ebuild b/kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110110.ebuild
deleted file mode 100644
index 8079478918e7..000000000000
--- a/kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110110.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110110.ebuild,v 1.3 2011/04/28 19:36:00 ottxor Exp $
-
-EAPI="3"
-
-inherit kde4-base
-
-DESCRIPTION="A upnp KIO slave for KDE"
-HOMEPAGE="https://projects.kde.org/projects/playground/base/kio-upnp-ms"
-SRC_URI="mirror://gentoo/kio-upnp-ms-0.8.0_p20110110.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="~media-libs/herqq-0.8.0
- kde-base/kdelibs
- x11-libs/qt-core"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- cp "${FILESDIR}"/FindHUpnp.cmake "${T}" || die
- kde4-base_src_prepare || die
- mycmakeargs=( -DCMAKE_MODULE_PATH="${T}" -DHUPNP_INCLUDE_DIR="${EPREFIX}/usr/include" )
-}
diff --git a/kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110313.ebuild b/kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110313.ebuild
index 851197bf523b..e11273ee7377 100644
--- a/kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110313.ebuild
+++ b/kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110313.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110313.ebuild,v 1.2 2011/04/28 19:36:00 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-upnp-ms/kio-upnp-ms-0.8.0_p20110313.ebuild,v 1.3 2011/04/28 20:27:08 scarabeus Exp $
-EAPI="3"
+EAPI=4
inherit kde4-base
@@ -15,14 +15,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="~media-libs/herqq-1.0.0
- kde-base/kdelibs
- x11-libs/qt-core"
+RDEPEND=">=media-libs/herqq-1.0.0"
DEPEND="${RDEPEND}"
src_prepare() {
- sed -i -e '/HUPNP_VER/s/0/1/' -e '/HUPNP_VER/s/9/0/' CMakeLists.txt || die
- cp "${FILESDIR}"/FindHUpnp.cmake "${T}" || die
- kde4-base_src_prepare || die
- mycmakeargs=( -DCMAKE_MODULE_PATH="${T}" -DHUPNP_INCLUDE_DIR="${EPREFIX}/usr/include" )
+ mkdir -p "${S}/cmake/modules/" || die
+ cp "${FILESDIR}"/FindHUpnp.cmake "${S}/cmake/modules/" || die
+ sed -i '6 a \
+set(CMAKE_MODULE_PATH \${CMAKE_MODULE_PATH} \${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)' \
+ ${S}/CMakeLists.txt || die
+ kde4-base_src_prepare
}