summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.31.ebuild')
-rw-r--r--mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.31.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.31.ebuild b/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.31.ebuild
new file mode 100644
index 000000000000..20e970e6e94e
--- /dev/null
+++ b/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.31.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.31.ebuild,v 1.1 2011/08/30 10:32:49 fauli Exp $
+
+inherit eutils
+
+MY_P="${PN#claws-mail-}2_viewer-${PV}"
+
+DESCRIPTION="Renders HTML mail using the gtkhtml2 rendering widget."
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.7.10
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --disable-accessibility || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}