summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/inkscape')
-rw-r--r--media-gfx/inkscape/ChangeLog6
-rw-r--r--media-gfx/inkscape/files/string.patch11
-rw-r--r--media-gfx/inkscape/inkscape-0.38.1.ebuild7
3 files changed, 22 insertions, 2 deletions
diff --git a/media-gfx/inkscape/ChangeLog b/media-gfx/inkscape/ChangeLog
index 11df593a0df3..3fff628b4c70 100644
--- a/media-gfx/inkscape/ChangeLog
+++ b/media-gfx/inkscape/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/inkscape
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/ChangeLog,v 1.6 2004/05/25 10:11:13 zypher Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/ChangeLog,v 1.7 2004/06/14 15:55:59 hanno Exp $
+
+ 14 Jun 2004; Hanno Boeck <hanno@gentoo.org> +files/string.patch,
+ inkscape-0.38.1.ebuild:
+ Compilation fix for gcc 3.4.
25 May 2004; Marc Hildebrand <zypher@gentoo.org> inkscape-0.38.1.ebuild:
Changed libsigc++ dep from >=v.1.2 to =v.1.2* resolves bug #51325.
diff --git a/media-gfx/inkscape/files/string.patch b/media-gfx/inkscape/files/string.patch
new file mode 100644
index 000000000000..06490a8ffed1
--- /dev/null
+++ b/media-gfx/inkscape/files/string.patch
@@ -0,0 +1,11 @@
+--- inkscape-0.38.1/src/libnr/nr-maybe.h 2004/04/22 11:17:19 1.1
++++ inkscape-0.38.1/src/libnr/nr-maybe.h 2004/04/22 11:17:52
+@@ -24,7 +24,7 @@
+ /** An exception class for run-time type errors */
+ template <typename T>
+ class IsNot : public std::domain_error {
+- IsNot() : domain_error(string("Is not ") + typeid(T).name()) {}
++ IsNot() : domain_error(std::string("Is not ") + typeid(T).name()) {}
+ };
+
+ /** A type with only one value, which (in principle) is only equal to itself.
diff --git a/media-gfx/inkscape/inkscape-0.38.1.ebuild b/media-gfx/inkscape/inkscape-0.38.1.ebuild
index bfe928af788a..ad675c712c29 100644
--- a/media-gfx/inkscape/inkscape-0.38.1.ebuild
+++ b/media-gfx/inkscape/inkscape-0.38.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.38.1.ebuild,v 1.3 2004/05/25 10:11:13 zypher Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.38.1.ebuild,v 1.4 2004/06/14 15:55:59 hanno Exp $
inherit gnome2
@@ -34,4 +34,9 @@ G2CONF="${G2CONF} --with-xft --with-popt"
use mmx || G2CONF="${G2CONF} --disable-mmx"
use gnome && G2CONF="${G2CONF} --with-gnome-print"
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/string.patch
+}
+
DOCS="AUTHORS COPYING ChangeLog HACKING NEWS README"