summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/zphoto/zphoto-1.2-r1.ebuild')
-rw-r--r--media-gfx/zphoto/zphoto-1.2-r1.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/media-gfx/zphoto/zphoto-1.2-r1.ebuild b/media-gfx/zphoto/zphoto-1.2-r1.ebuild
index f067e011420e..57b1e7092b59 100644
--- a/media-gfx/zphoto/zphoto-1.2-r1.ebuild
+++ b/media-gfx/zphoto/zphoto-1.2-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/zphoto-1.2-r1.ebuild,v 1.5 2006/11/06 18:32:14 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/zphoto-1.2-r1.ebuild,v 1.6 2007/04/23 02:03:49 dirtyepic Exp $
+
+inherit wxwidgets
IUSE="wxwindows"
@@ -16,23 +18,17 @@ DEPEND=">=media-libs/ming-0.2a
|| ( >=media-libs/imlib2-1.1.0 >=media-gfx/imagemagick-5.5.7 )
app-arch/zip
>=dev-libs/popt-1.6.3
- wxwindows? ( >=x11-libs/wxGTK-2.4.2-r2 )"
+ wxwindows? ( =x11-libs/wxGTK-2.6* )"
src_compile() {
local myconf="--disable-avifile"
if use wxwindows ; then
- if has_version '>=x11-libs/wxGTK-2.6' ; then
- wx_config="/usr/bin/wx-config-2.6"
- sed -i -e 's@\($WXCONFIG --cflags\)@\1 --unicode=no@' \
- -e 's@\($WXCONFIG --libs\)@\1 --unicode=no@' \
- configure || die
- sed -i -e 's@FALSE@false@g' wxzphoto.cpp || die
- else
- wx_config="/usr/bin/wxgtk2-2.4-config"
- fi
- myconf="--with-wx-config=$wx_config"
+ WX_GTK_VER="2.6"
+ need-wxwidgets gtk2
+ myconf="--with-wx-config=${WX_CONFIG}"
+ sed -i -e 's@FALSE@false@g' wxzphoto.cpp || die
else
myconf="--disable-wx"
fi