summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/allegrogl/allegrogl-0.2.4-r1.ebuild')
-rw-r--r--media-libs/allegrogl/allegrogl-0.2.4-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/media-libs/allegrogl/allegrogl-0.2.4-r1.ebuild b/media-libs/allegrogl/allegrogl-0.2.4-r1.ebuild
index 45a3cd9e0a5a..59ffba6f2e21 100644
--- a/media-libs/allegrogl/allegrogl-0.2.4-r1.ebuild
+++ b/media-libs/allegrogl/allegrogl-0.2.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegrogl/allegrogl-0.2.4-r1.ebuild,v 1.1 2005/03/12 16:08:40 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegrogl/allegrogl-0.2.4-r1.ebuild,v 1.2 2006/01/15 04:24:46 mr_bones_ Exp $
inherit eutils
@@ -11,19 +11,21 @@ SRC_URI="mirror://sourceforge/allegrogl/${MY_PN}-${PV}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="~amd64 ~sparc ~x86"
+KEYWORDS="~amd64 ~sparc x86"
IUSE="doc"
DEPEND=">=media-libs/allegro-4.0.0"
-S="${WORKDIR}/${MY_PN}"
+S=${WORKDIR}/${MY_PN}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-destdir.patch
- epatch ${FILESDIR}/${P}-noasm.patch
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-destdir.patch \
+ "${FILESDIR}"/${P}-noasm.patch \
+ "${FILESDIR}"/${P}-agl_write_line_c.patch
}
src_compile() {