summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libtheora/libtheora-1.0_alpha3.ebuild')
-rw-r--r--media-libs/libtheora/libtheora-1.0_alpha3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/libtheora/libtheora-1.0_alpha3.ebuild b/media-libs/libtheora/libtheora-1.0_alpha3.ebuild
new file mode 100644
index 000000000000..5f321aa7c751
--- /dev/null
+++ b/media-libs/libtheora/libtheora-1.0_alpha3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha3.ebuild,v 1.1 2004/03/21 21:57:04 mholzer Exp $
+
+DESCRIPTION="The Theora Video Compression Codec"
+HOMEPAGE="http://www.theora.org/"
+SRC_URI="http://www.theora.org/files/${P/_}.tar.gz
+ http://download.videolan.org/pub/videolan/vlc/0.7.0/contrib/${P/_}.tar.gz"
+
+LICENSE="xiph"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND=">=media-libs/libogg-1.1.0
+ >=media-libs/libvorbis-1.0.1"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's:SUBDIRS = .*:SUBDIRS = lib include doc:' Makefile.in
+}
+
+src_compile() {
+ econf --enable-shared || die
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc README
+}