summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/suil/suil-0.6.2.ebuild')
-rw-r--r--media-libs/suil/suil-0.6.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/suil/suil-0.6.2.ebuild b/media-libs/suil/suil-0.6.2.ebuild
new file mode 100644
index 000000000000..41156ab68478
--- /dev/null
+++ b/media-libs/suil/suil-0.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/suil/suil-0.6.2.ebuild,v 1.1 2012/05/31 22:23:55 aballier Exp $
+
+EAPI=4
+
+inherit base waf-utils
+
+DESCRIPTION="Lightweight C library for loading and wrapping LV2 plugin UIs"
+HOMEPAGE="http://drobilla.net/software/suil/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk qt4"
+
+RDEPEND="media-libs/lv2
+ gtk? ( x11-libs/gtk+:2 )
+ qt4? ( x11-libs/qt-gui:4 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/ldconfig.patch" )
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_configure() {
+ # otherwise automagic
+ use gtk || sed -i -e 's/gtk+-2.0/DiSaBlEd/' wscript
+ use qt4 || sed -i -e 's/QtGui/DiSaBlEd/' wscript
+ waf-utils_src_configure \
+ "--mandir=/usr/share/man" \
+ "--docdir=/usr/share/doc/${PF}" \
+ $(use doc && echo "--docs")
+}