summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/abcm2ps/abcm2ps-5.9.24.ebuild')
-rw-r--r--media-sound/abcm2ps/abcm2ps-5.9.24.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/abcm2ps/abcm2ps-5.9.24.ebuild b/media-sound/abcm2ps/abcm2ps-5.9.24.ebuild
new file mode 100644
index 000000000000..8e77842fc20b
--- /dev/null
+++ b/media-sound/abcm2ps/abcm2ps-5.9.24.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/abcm2ps-5.9.24.ebuild,v 1.1 2011/08/22 08:22:15 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="A program to convert abc files to Postscript files"
+HOMEPAGE="http://moinejf.free.fr/"
+SRC_URI="http://moinejf.free.fr/${P}.tar.gz
+ http://moinejf.free.fr/transpose_abc.pl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+src_prepare() {
+ sed -i \
+ -e '/LDFLAGS/s:=.*:= @LDFLAGS@:' \
+ Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --enable-a4 \
+ --enable-deco-is-roll
+}
+
+src_install() {
+ dobin abcm2ps
+
+ insinto /usr/share/${PN}
+ doins *.fmt
+
+ dodoc Changes README *.txt
+
+ if use examples ; then
+ docinto examples
+ dodoc *.{abc,eps}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ docinto contrib
+ dodoc "${DISTDIR}"/transpose_abc.pl
+}