summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mp3blaster/mp3blaster-3.2.3.ebuild')
-rw-r--r--media-sound/mp3blaster/mp3blaster-3.2.3.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild b/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild
index 5eea82bf274e..0136543d8cb9 100644
--- a/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild
+++ b/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild,v 1.1 2006/12/11 19:41:57 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild,v 1.2 2007/03/01 18:54:46 aballier Exp $
inherit toolchain-funcs
@@ -20,6 +20,10 @@ DEPEND=">=sys-libs/ncurses-5.2
src_compile() {
local myconf
+ # Prevents collisions with media-sound/splay
+ sed -i "s/splay.1/splay_mp3blaster.1/" Makefile.in\
+ || die "sedding makefile failed"
+ mv splay.1 splay_mp3blaster.1 || die "renaming splay man failed"
### Looks like NAS support is broken, at least with NAS 1.5 and
### mp3player 3.1.1 (Aug 13, agenkin@thpoon.com)
### Ditto nas-1.6c-r1, mp3blaster-3.2.0 (2004.06.23 - eradicator)
@@ -33,6 +37,9 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
+ # Prevent collisions with media-sound/splay
+ mv "${D}/usr/bin/splay" "${D}/usr/bin/splay_mp3blaster"\
+ || die "moving splay to splay_mp3blaster failed"
dodoc ANNOUNCE AUTHORS CREDITS ChangeLog FAQ NEWS README TODO
}