summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/xmms')
-rw-r--r--media-sound/xmms/ChangeLog9
-rw-r--r--media-sound/xmms/Manifest2
-rw-r--r--media-sound/xmms/files/digest-xmms-1.2.10-r104
-rwxr-xr-xmedia-sound/xmms/files/po-update.pl367
-rw-r--r--media-sound/xmms/xmms-1.2.10-r10.ebuild158
5 files changed, 539 insertions, 1 deletions
diff --git a/media-sound/xmms/ChangeLog b/media-sound/xmms/ChangeLog
index 122a117d30dc..48f72e917d10 100644
--- a/media-sound/xmms/ChangeLog
+++ b/media-sound/xmms/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/xmms
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/ChangeLog,v 1.154 2005/01/04 15:03:50 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/ChangeLog,v 1.155 2005/01/23 00:55:45 eradicator Exp $
+
+*xmms-1.2.10-r10 (22 Jan 2005)
+
+ 22 Jan 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/po-update.pl, +xmms-1.2.10-r10.ebuild:
+ Revbump to latest upstream cvs. Added a skin dir browser and numberic keypad
+ controls. This should fix bug #71262.
04 Jan 2005; Markus Rothe <corsair@gentoo.org> xmms-1.2.10-r5.ebuild,
xmms-1.2.10-r9.ebuild:
diff --git a/media-sound/xmms/Manifest b/media-sound/xmms/Manifest
index 2c025d049871..87a0b5afe939 100644
--- a/media-sound/xmms/Manifest
+++ b/media-sound/xmms/Manifest
@@ -3,7 +3,9 @@ MD5 5a8290e44006ccff0dff3094555d6366 metadata.xml 257
MD5 33b564ef94a980547348ae5478c6fd24 xmms-1.2.10-r5.ebuild 5545
MD5 bd2c29d7bc96c9f8c558e0fdcccd941a xmms-1.2.10-r9.ebuild 3402
MD5 1f4aab1f3653bb6e5fb441d038160e52 xmms-1.2.8-r4.ebuild 5246
+MD5 35d0148d42b3631d5b1d2911b55cc2d2 xmms-1.2.10-r10.ebuild 3402
MD5 aa46b23a1cf0655c7f09adbdd623d49f files/digest-xmms-1.2.10-r5 219
MD5 07a3ee1ff0ac863b041b89319a01bf32 files/digest-xmms-1.2.10-r9 277
MD5 f52f09b25da87c876de70b6177292f2e files/digest-xmms-1.2.8-r4 216
MD5 7d2f3807ebbff435b909ecf0539cbf4f files/xmms.desktop 722
+MD5 964b9054ef6250cdbff148b3f56ea9bc files/digest-xmms-1.2.10-r10 277
diff --git a/media-sound/xmms/files/digest-xmms-1.2.10-r10 b/media-sound/xmms/files/digest-xmms-1.2.10-r10
new file mode 100644
index 000000000000..e82f9c3dbaed
--- /dev/null
+++ b/media-sound/xmms/files/digest-xmms-1.2.10-r10
@@ -0,0 +1,4 @@
+MD5 03a85cfc5e1877a2e1f7be4fa1d3f63c xmms-1.2.10.tar.bz2 2418265
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+MD5 9204e71b49492031aa69838584caacd8 xmms-1.2.10-gentoo-patches-2.1.6.tar.bz2 534534
+MD5 fe54f2ec779bc995176e63e3e77cca11 gnomexmms.xpm 7979
diff --git a/media-sound/xmms/files/po-update.pl b/media-sound/xmms/files/po-update.pl
new file mode 100755
index 000000000000..48983c6595b2
--- /dev/null
+++ b/media-sound/xmms/files/po-update.pl
@@ -0,0 +1,367 @@
+#!/usr/bin/perl -w
+
+#
+# GNOME PO Update Utility
+#
+# Copyright (C) 2000 Free Software Foundation.
+#
+# This script is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This script is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this library; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+# Authors: Kenneth Christiansen <kenneth@gnu.org>
+#
+
+# NOTICE: Please remember to change the variable $PACKAGE to reflect
+# the package this script is used within.
+
+$PACKAGE="xmms";
+
+use File::Basename;
+
+# Declare global variables
+#-------------------------
+my $VERSION = "1.5beta5";
+my $LANG = $ARGV[0];
+
+# Always print as the first thing
+#--------------------------------
+$| = 1;
+
+# Figure out what package that is in use
+#---------------------------------------
+#open FILE, "../configure.in";
+# while (<FILE>) {
+# next if /^dnl/; #ignore comments
+# if ($_=~/AM_INIT_AUTOMAKE\((.*),(.*)\)/o){
+# $PACKAGE=$1;
+# last; #stop when found
+# }
+# if ($_=~/PACKAGE\((.*)\)/o){
+# $PACKAGE=$1;
+# last; #stop when found
+# }
+# }
+#close FILE;
+
+
+# Give error if script is run without an argument
+#------------------------------------------------
+if (! $LANG){
+ print "update.pl: missing file arguments\n";
+ print "Try `update.pl --help' for more information.\n";
+ exit;
+}
+
+# Use the supplied arguments
+#---------------------------
+if ($LANG=~/^-(.)*/){
+
+ if ("$LANG" eq "--version" || "$LANG" eq "-V"){
+ &Version;
+ }
+ elsif ($LANG eq "--help" || "$LANG" eq "-H"){
+ &Help;
+ }
+ elsif ($LANG eq "--dist" || "$LANG" eq "-D"){
+ &Merging;
+ }
+ elsif ($LANG eq "--pot" || "$LANG" eq "-P"){
+
+ # Check for .headerlock file, so the Makefile
+ # will not generate the header files twise
+ #--------------------------------------------
+ if (-e ".headerlock"){
+ &GeneratePot;
+ }else{
+ &GenHeaders;
+ &GeneratePot;}
+ exit;
+ }
+ elsif ($LANG eq "--headers" || "$LANG" eq "-S"){
+ &GenHeaders;
+ exit;
+ }
+ elsif ($LANG eq "--maintain" || "$LANG" eq "-M"){
+ &Maintain;
+ }
+ else {
+ &InvalidOption;
+ }
+
+} else {
+
+ # Run standard procedure
+ #-----------------------
+ if(-s "$LANG.po"){
+ &GenHeaders;
+ &GeneratePot;
+ &Merging;
+ &Status;
+ }
+
+ # Report error if the language file supplied
+ # to the command line is non-existent
+ #-------------------------------------------
+ else {
+ &NotExisting;
+ }
+}
+
+sub Version{
+
+ # Print version information
+ #--------------------------
+ print "GNOME PO Updater $VERSION\n";
+ print "Written by Kenneth Christiansen <kenneth\@gnome.org>, 2000.\n\n";
+ print "Copyright (C) 2000 Free Software Foundation, Inc.\n";
+ print "This is free software; see the source for copying conditions. There is NO\n";
+ print "warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n";
+ exit;
+}
+
+sub Help{
+
+ # Print usage information
+ #------------------------
+ print "Usage: ./update.pl [OPTIONS] ...LANGCODE\n";
+ print "Updates pot files and merge them with the translations.\n\n";
+ print " -H, --help shows this help page\n";
+ print " -P, --pot generate the pot file only\n";
+ print " -S, --headers generate the XML headerfiles in POTFILES.in\n";
+ print " -M, --maintain search for missing files in POTFILES.in\n";
+ print " -V, --version shows the version\n";
+ print "\nExamples of use:\n";
+ print "update.sh --pot just creates a new pot file from the source\n";
+ print "update.sh da created new pot file and updated the da.po file\n\n";
+ print "Report bugs to <kenneth\@gnome.org>.\n";
+ exit;
+}
+
+sub Maintain{
+
+ # Search and fine, all translatable files
+ # ---------------------------------------
+ $i18nfiles="find ../ -print | egrep '.*\\.(c|y|cc|c++|h|gob)' ";
+
+ open(BUF2, "POTFILES.in") || die "update.pl: there's no POTFILES.in!!!\n";
+
+ print "Searching for missing _(\" \") entries...\n";
+
+ open(BUF1, "$i18nfiles|");
+
+ @buf1_1 = <BUF1>;
+ @buf1_2 = <BUF2>;
+
+ # Check if we should ignore some found files, when
+ # comparing with POTFILES.in
+ #-------------------------------------------------
+ if (-s ".potignore"){
+ open FILE, ".potignore";
+ while (<FILE>) {
+ if ($_=~/^[^#]/o){
+ push @bup, $_;
+ }
+ }
+ print "Found .potignore: Ignoring files...\n";
+ @buf1_2 = (@bup, @buf1_2);
+ }
+
+ foreach my $file (@buf1_1){
+ open FILE, "<$file";
+ while (<FILE>) {
+ if ($_=~/_\(\"/o){
+ $file = unpack("x3 A*",$file) . "\n";
+ push @buf2_1, $file;
+ last;
+ }
+ }
+ }
+
+ @buf3_1 = sort (@buf2_1);
+ @buf3_2 = sort (@buf1_2);
+
+ my %in2;
+ foreach (@buf3_2) {
+ $in2{$_} = 1;
+ }
+
+ foreach (@buf3_1){
+ if (!exists($in2{$_})){
+ push @result, $_
+ }
+ }
+
+ # Save file with information about the files missing
+ # if any, and give information about this proceedier
+ #---------------------------------------------------
+ if(@result){
+ open OUT, ">missing";
+ print OUT @result;
+ print "\nHere is the result:\n\n", @result, "\n";
+ print "The file \"missing\" has been placed in the current directory.\n";
+ print "Files supposed to be ignored should be placed in \".potignore\"\n";
+ }
+
+ # If there is nothing to complain about, notice the user
+ #-------------------------------------------------------
+ else{
+ print "\nWell, it's all perfect! Congratulation!\n";
+ }
+}
+
+sub InvalidOption{
+
+ # Handle invalid arguments
+ #-------------------------
+ print "update.pl: invalid option -- $LANG\n";
+ print "Try `update.pl --help' for more information.\n";
+}
+
+sub GenHeaders{
+
+ # Generate the .h header files, so we can allow glade and
+ # xml translation support
+ #--------------------------------------------------------
+ if(-s "ui-extract.pl"){
+
+ print "Found ui-extract.pl script\nRunning ui-extract...\n";
+
+ open FILE, "<POTFILES.in";
+ while (<FILE>) {
+
+ # Find .xml files in POTFILES.in and generate the
+ # files with help from the ui-extract.pl script
+ #--------------------------------------------------
+ if ($_=~ /(.*)(\.xml)/o){
+ $filename = "../$1.xml";
+ $xmlfiles="perl \.\/ui-extract.pl --local $filename";
+ system($xmlfiles);
+ }
+
+ # Find .glade files in POTFILES.in and generate
+ # the files with help from the ui-extract.pl script
+ #--------------------------------------------------
+ elsif ($_=~ /(.*)(\.glade)/o){
+ $filename = "../$1.glade";
+ $xmlfiles="perl \.\/ui-extract.pl --local $filename";
+ system($xmlfiles);
+ }
+ }
+ close FILE;
+
+ # Create .headerlock file, so the script will know
+ # that we already passed this section. This is required
+ # since the individual sections can be reaced at different
+ # times by the Makefile
+ #---------------------------------------------------------
+ system("touch .headerlock");
+ }
+}
+
+sub GeneratePot{
+
+ # Generate the potfiles from the POTFILES.in file
+ #------------------------------------------------
+
+ print "Building the $PACKAGE.pot...\n";
+
+ system ("mv POTFILES.in POTFILES.in.old");
+
+ open INFILE, "<POTFILES.in.old";
+ open OUTFILE, ">POTFILES.in";
+ while (<INFILE>) {
+ if ($_ =~ /\.(glade|xml)$/) {
+ s/\.glade$/\.glade\.h/;
+ s/\.xml$/\.xml\.h/;
+ $_ = basename($_);
+ $_ = "po/tmp/$_\n";
+ }
+ print OUTFILE $_;
+ }
+ close OUTFILE;
+ close INFILE;
+
+ $GETTEXT ="xgettext --default-domain\=$PACKAGE --directory\=\.\."
+ ." --add-comments --keyword\=\_ --keyword\=N\_"
+ ." --files-from\=\.\/POTFILES\.in ";
+ $GTEST ="test \! -f $PACKAGE\.po \|\| \( rm -f \.\/$PACKAGE\.pot "
+ ."&& mv $PACKAGE\.po \.\/$PACKAGE\.pot \)";
+
+ system($GETTEXT);
+ system($GTEST);
+ print "Wrote $PACKAGE.pot\n";
+ system("mv POTFILES.in.old POTFILES.in");
+
+ # If .headerlock file is found, it means that the potfiles
+ # already has been generated. If so delete the generated
+ # .h header files. The reason for this approach with a
+ # file as a marker is due to that the Makefile runs the
+ # scripts in turns
+ #---------------------------------------------------------
+
+ if(-e ".headerlock"){
+ unlink(".headerlock");
+
+ print "Removing generated header (.h) files...";
+ system("rm ./tmp/ -rf");
+ }
+ print "done\n";
+}
+
+sub Merging{
+
+ if ($ARGV[1]){
+ $LANG = $ARGV[1];
+ } else {
+ $LANG = $ARGV[0];
+ }
+
+ if ($ARGV[0] ne "--dist" && $ARGV[0] ne "-D") {
+ print "Merging $LANG.po with $PACKAGE.pot...";
+ }
+
+ $MERGE="cp $LANG.po $LANG.po.old && msgmerge $LANG.po.old $PACKAGE.pot -o $LANG.po";
+
+ system($MERGE);
+
+ if ($ARGV[0] ne "--dist" && $ARGV[0] ne "-D") {
+ print "\n\n";
+ }
+
+ # Remove the "messages" trash file generated
+ # by gettext, aswell as the backup file
+ #-------------------------------------------
+ unlink "messages";
+ unlink "$LANG.po.old";
+}
+
+sub NotExisting{
+
+ # Report error if supplied language
+ # file is non-existant
+ #----------------------------------
+ print "update.pl: sorry, $LANG.po does not exist!\n";
+ print "Try `update.pl --help' for more information.\n";
+ exit;
+}
+
+sub Status{
+
+ # Print status information about the po file
+ #-------------------------------------------
+ $STATUS="msgfmt --statistics $LANG.po";
+
+ system($STATUS);
+ print "\n";
+}
diff --git a/media-sound/xmms/xmms-1.2.10-r10.ebuild b/media-sound/xmms/xmms-1.2.10-r10.ebuild
new file mode 100644
index 000000000000..9f65a39494fa
--- /dev/null
+++ b/media-sound/xmms/xmms-1.2.10-r10.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/xmms-1.2.10-r10.ebuild,v 1.1 2005/01/23 00:55:45 eradicator Exp $
+
+inherit flag-o-matic eutils libtool gnuconfig
+
+PATCHVER="2.1.6"
+
+PATCHDIR="${WORKDIR}/patches"
+
+DESCRIPTION="X MultiMedia System"
+HOMEPAGE="http://www.xmms.org/"
+SRC_URI="http://www.xmms.org/files/1.2.x/${P}.tar.bz2
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2
+ http://dev.gentoo.org/~eradicator/xmms/${P}-gentoo-patches-${PATCHVER}.tar.bz2
+ http://dev.gentoo.org/~eradicator/xmms/gnomexmms.xpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Notice to arch maintainers:
+# Please test out the plugins listed below in PDEPEND. They should
+# work on most of your archs, but haven't been marked yet.
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xml nls esd opengl mmx oggvorbis 3dnow mikmod directfb ipv6 alsa oss arts jack sndfile lirc flac mad"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ mikmod? ( >=media-libs/libmikmod-3.1.10 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ xml? ( >=dev-libs/libxml-1.8.15 )
+ opengl? ( virtual/opengl )
+ alsa? ( >=media-libs/alsa-lib-0.9.0 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )"
+
+RDEPEND="${DEPEND}
+ directfb? ( dev-libs/DirectFB )
+ app-arch/unzip"
+
+#We want these things in DEPEND only
+DEPEND="${DEPEND}
+ >=sys-devel/automake-1.7
+ >=sys-devel/autoconf-2.5
+ sys-devel/libtool
+ nls? ( dev-util/intltool
+ dev-lang/perl
+ sys-devel/gettext )"
+
+# USE flags pull in xmms plugins
+PDEPEND="!alpha? ( !mips? ( !ppc64? ( jack? ( media-plugins/xmms-jack ) ) ) )
+ !alpha? ( !ppc64? ( lirc? ( media-plugins/xmms-lirc ) ) )
+ !ppc64? ( arts? ( media-plugins/xmms-arts ) )
+ !alpha? ( !mips? ( !ppc64? ( sndfile? ( media-plugins/xmms-sndfile ) ) ) )
+ !alpha? ( !mips? ( mad? ( >=media-plugins/xmms-mad-0.7 ) ) )
+ flac? ( media-libs/flac )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ EPATCH_SUFFIX="patch"
+ epatch ${PATCHDIR}
+
+ export WANT_AUTOMAKE=1.7
+ export WANT_AUTOCONF=2.5
+
+ cd ${S}
+ libtoolize --force --copy
+ aclocal
+ autoheader
+ automake --gnu --add-missing --include-deps --force-missing --copy
+ autoconf
+
+ cd ${S}/libxmms
+ libtoolize --force --copy
+ ln -s ../ltmain.sh
+ aclocal
+ autoheader
+ automake --gnu --add-missing --include-deps --force-missing --copy
+ autoconf
+
+ if use nls; then
+ cd ${S}/po
+ cp ${FILESDIR}/po-update.pl update.pl
+ perl update.pl --pot
+ fi
+
+ cd ${S}
+ gnuconfig_update
+}
+
+src_compile() {
+ filter-flags -fforce-addr -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+
+ local myconf=""
+
+ if use amd64; then
+ myconf="${myconf} --disable-simd"
+ else
+ if use 3dnow || use mmx; then
+ myconf="${myconf} --enable-simd"
+ else
+ myconf="${myconf} --disable-simd"
+ fi
+ fi
+
+ use xml || myconf="${myconf} --disable-cdindex"
+
+ if [ -e /dev/sound ]; then
+ myconf="${myconf} \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer"
+ fi
+
+ # Please see Bug 58092 for details
+ use ppc64 && replace-flags "-O[2-9]" "-O1"
+
+ econf `use_enable oggvorbis vorbis` \
+ `use_enable esd` \
+ `use_enable mikmod` \
+ `use_with mikmod libmikmod` \
+ `use_enable opengl` \
+ `use_enable nls` \
+ `use_enable ipv6` \
+ `use_enable oss oss` \
+ ${myconf} \
+ || die
+
+ # For some reason, gmake doesn't export this for libtool's consumption
+ export EGREP="grep -E"
+ emake -j1 || die
+}
+
+src_install() {
+ export EGREP="grep -E"
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO
+ newdoc ${PATCHDIR}/README README.patches
+ newdoc ${PATCHDIR}/ChangeLog ChangeLog.patches
+
+ keepdir /usr/share/xmms/Skins
+ insinto /usr/share/pixmaps/
+ newins ${DISTDIR}/gnomexmms.xpm xmms.xpm
+ doins xmms/xmms_logo.xpm
+ insinto /usr/share/pixmaps/mini
+ doins xmms/xmms_mini.xpm
+
+ insinto /etc/X11/wmconfig
+ donewins xmms/xmms.wmconfig xmms
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/xmms.desktop
+
+ # Add the sexy Gentoo Ice skin
+ insinto /usr/share/xmms/Skins/gentoo_ice
+ doins ${WORKDIR}/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc ${WORKDIR}/README
+}