summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/abcde/abcde-1.9.9.ebuild3
-rw-r--r--media-sound/abcde/files/abcde-1.9.9-gentoo.diff29
-rw-r--r--media-sound/cd-discid/cd-discid-0.6.ebuild3
-rw-r--r--media-sound/cdparanoia/cdparanoia-3.9.8.ebuild7
-rw-r--r--media-sound/dcd/dcd-0.90.ebuild4
-rw-r--r--media-sound/id3/id3-0.12-r1.ebuild4
-rw-r--r--media-sound/mpg123/mpg123-0.59r.ebuild6
-rw-r--r--media-sound/shorten/shorten-3.2.ebuild4
8 files changed, 33 insertions, 27 deletions
diff --git a/media-sound/abcde/abcde-1.9.9.ebuild b/media-sound/abcde/abcde-1.9.9.ebuild
index 567e8e1529b6..1e191d98a5b7 100644
--- a/media-sound/abcde/abcde-1.9.9.ebuild
+++ b/media-sound/abcde/abcde-1.9.9.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcde/abcde-1.9.9.ebuild,v 1.1 2001/04/23 01:00:39 pete Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcde/abcde-1.9.9.ebuild,v 1.2 2001/05/28 05:24:13 achim Exp $
A=${PN}_${PV}.orig.tar.gz
@@ -17,6 +17,7 @@ src_unpack() {
unpack ${A}
cd ${S}
+ cp Makefile Makefile.orig
patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
}
diff --git a/media-sound/abcde/files/abcde-1.9.9-gentoo.diff b/media-sound/abcde/files/abcde-1.9.9-gentoo.diff
index 2f9bde642d79..09eaf3bc0797 100644
--- a/media-sound/abcde/files/abcde-1.9.9-gentoo.diff
+++ b/media-sound/abcde/files/abcde-1.9.9-gentoo.diff
@@ -1,15 +1,3 @@
-diff -ur abcde-1.9.9.orig/Makefile abcde-1.9.9/Makefile
---- abcde-1.9.9.orig/Makefile Tue Mar 13 10:49:02 2001
-+++ abcde-1.9.9/Makefile Mon Apr 16 20:05:43 2001
-@@ -6,7 +6,7 @@
- exec_prefix = ${prefix}
- mandir = ${prefix}/share/man/man1
- bindir = ${exec_prefix}/bin
--etcdir = ${DESTDIR}/etc
-+etcdir = ${DESTDIR}/etc/abcde
-
- all:
-
diff -ur abcde-1.9.9.orig/abcde abcde-1.9.9/abcde
--- abcde-1.9.9.orig/abcde Tue Mar 13 10:49:24 2001
+++ abcde-1.9.9/abcde Mon Apr 16 21:14:26 2001
@@ -46,3 +34,20 @@ diff -ur abcde-1.9.9.orig/abcde abcde-1.9.9/abcde
# Load user preference defaults
if [ -r $HOME/.abcde.conf ]; then
Only in abcde-1.9.9: abcde~
+--- abcde-1.9.9/Makefile.orig Sun May 27 14:36:26 2001
++++ abcde-1.9.9/Makefile Sun May 27 14:36:38 2001
+@@ -1,12 +1,12 @@
+ VERSION = 1.9.9
+-INSTALL = /usr/bin/install -c
++INSTALL = /bin/install -c
+
+ # Installation directories
+ prefix = ${DESTDIR}/usr
+ exec_prefix = ${prefix}
+ mandir = ${prefix}/share/man/man1
+ bindir = ${exec_prefix}/bin
+-etcdir = ${DESTDIR}/etc
++etcdir = ${DESTDIR}/etc/abcde
+
+ all:
+
diff --git a/media-sound/cd-discid/cd-discid-0.6.ebuild b/media-sound/cd-discid/cd-discid-0.6.ebuild
index 03e7780f7efa..e6cc375eaf84 100644
--- a/media-sound/cd-discid/cd-discid-0.6.ebuild
+++ b/media-sound/cd-discid/cd-discid-0.6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cd-discid/cd-discid-0.6.ebuild,v 1.1 2001/04/23 01:00:39 pete Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cd-discid/cd-discid-0.6.ebuild,v 1.2 2001/05/28 05:24:13 achim Exp $
A=${PN}_${PV}.orig.tar.gz
S=${WORKDIR}/${P}
@@ -9,6 +9,7 @@ DESCRIPTION="returns the disc id for the cd in the cd-rom drive"
SRC_URI="http://lly.org/~rcw/cd-discid/${A}"
HOMEPAGE="http://lly.org/~rcw/abcde/page/"
+DEPEND="virtual/glibc"
src_compile() {
diff --git a/media-sound/cdparanoia/cdparanoia-3.9.8.ebuild b/media-sound/cdparanoia/cdparanoia-3.9.8.ebuild
index 70532dc3d93e..fa0700f73cc6 100644
--- a/media-sound/cdparanoia/cdparanoia-3.9.8.ebuild
+++ b/media-sound/cdparanoia/cdparanoia-3.9.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cdparanoia/cdparanoia-3.9.8.ebuild,v 1.1 2001/04/23 01:00:39 pete Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cdparanoia/cdparanoia-3.9.8.ebuild,v 1.2 2001/05/28 05:24:13 achim Exp $
A=${PN}-III-alpha9.8.src.tgz
S=${WORKDIR}/${PN}-III-alpha9.8
@@ -9,11 +9,12 @@ DESCRIPTION="an advanced CDDA reader with error correction"
SRC_URI="http://www.xiph.org/paranoia/download/${A}"
HOMEPAGE="http://www.xiph.org/paranoia/index.html"
+DEPEND="virtual/glibc"
src_compile() {
- cd ${S}
+
try ./configure --prefix=/usr --host=${CHOST}
- try make
+ try make OPT=\"$CFLAGS\"
}
src_install () {
diff --git a/media-sound/dcd/dcd-0.90.ebuild b/media-sound/dcd/dcd-0.90.ebuild
index 5dade004746d..d5b2ed2eaa47 100644
--- a/media-sound/dcd/dcd-0.90.ebuild
+++ b/media-sound/dcd/dcd-0.90.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.technopagan.org/dcd"
DESCRIPTION="A simple command-line based CD Player"
-DEPEND=">=sys-libs/glibc-2.1.3"
+DEPEND="virtual/glibc"
src_unpack() {
@@ -25,7 +25,7 @@ src_unpack() {
src_compile() {
- try make
+ try make EXTRA_CFLAGS=\"$CFLAGS\"
}
diff --git a/media-sound/id3/id3-0.12-r1.ebuild b/media-sound/id3/id3-0.12-r1.ebuild
index 32b738a75b38..e3dbc7acec90 100644
--- a/media-sound/id3/id3-0.12-r1.ebuild
+++ b/media-sound/id3/id3-0.12-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/id3/id3-0.12-r1.ebuild,v 1.1 2001/04/23 01:00:39 pete Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/id3/id3-0.12-r1.ebuild,v 1.2 2001/05/28 05:24:13 achim Exp $
A=${PN}_${PV}.orig.tar.gz
S=${WORKDIR}/${P}
@@ -17,7 +17,7 @@ src_compile() {
src_install () {
- try make DESTDIR=${D} install
+ try make DESTDIR=${D} INSTALL=\"/bin/install -c\" install
dodoc COPYING README
}
diff --git a/media-sound/mpg123/mpg123-0.59r.ebuild b/media-sound/mpg123/mpg123-0.59r.ebuild
index 583aaf84b0ba..35cbe6ff7b15 100644
--- a/media-sound/mpg123/mpg123-0.59r.ebuild
+++ b/media-sound/mpg123/mpg123-0.59r.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.59r.ebuild,v 1.4 2000/11/02 02:17:13 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.59r.ebuild,v 1.5 2001/05/28 05:24:13 achim Exp $
P=mpg123-0.59r
A=${P}.tar.gz
@@ -10,7 +10,7 @@ DESCRIPTION="Real Time mp3 player"
SRC_URI="http://www.mpg123.de/mpg123/${A}"
HOMEPAGE="http://www.mpg123.de/"
-DEPEND=">=sys-libs/glibc-2.1.3"
+DEPEND="virtual/glibc"
src_unpack () {
unpack ${A}
@@ -21,14 +21,12 @@ src_unpack () {
src_compile() {
- cd ${S}
try make linux-i486
}
src_install () {
- cd ${S}
into /usr
dobin mpg123
doman mpg123.1
diff --git a/media-sound/shorten/shorten-3.2.ebuild b/media-sound/shorten/shorten-3.2.ebuild
index 7e2073a0602a..c30905b5ba49 100644
--- a/media-sound/shorten/shorten-3.2.ebuild
+++ b/media-sound/shorten/shorten-3.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shorten/shorten-3.2.ebuild,v 1.1 2001/01/16 05:22:17 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shorten/shorten-3.2.ebuild,v 1.2 2001/05/28 05:24:13 achim Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Open source, popular and fast lossless audio compressor"
SRC_URI="http://shnutils.freeshell.org/misc/shorten-3.2.tar.gz"
-DEPEND=">=sys-libs/glibc-2.1.3"
+DEPEND="virtual/glibc"
src_unpack() {
unpack ${A}