summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpd-svn/ChangeLog7
-rw-r--r--media-sound/mpd-svn/Manifest12
-rw-r--r--media-sound/mpd-svn/files/digest-mpd-svn-200508231
-rw-r--r--media-sound/mpd-svn/mpd-svn-20050823.ebuild129
4 files changed, 138 insertions, 11 deletions
diff --git a/media-sound/mpd-svn/ChangeLog b/media-sound/mpd-svn/ChangeLog
index 822eef512bc8..313292ee64a9 100644
--- a/media-sound/mpd-svn/ChangeLog
+++ b/media-sound/mpd-svn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mpd-svn
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd-svn/ChangeLog,v 1.16 2005/07/30 22:21:08 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd-svn/ChangeLog,v 1.17 2005/08/23 15:39:15 ticho Exp $
+
+*mpd-svn-20050823 (23 Aug 2005)
+
+ 23 Aug 2005; Andrej Kacian <ticho@gentoo.org> +mpd-svn-20050823.ebuild:
+ Updated snapshot.
*mpd-svn-20050731 (30 Jul 2005)
diff --git a/media-sound/mpd-svn/Manifest b/media-sound/mpd-svn/Manifest
index 325c3f5cc859..822e577f756b 100644
--- a/media-sound/mpd-svn/Manifest
+++ b/media-sound/mpd-svn/Manifest
@@ -1,20 +1,12 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 1e7cf3dbea0c71acfd3656c55aa1870a mpd-svn-20050731.ebuild 3943
MD5 51fc9629c4887379b64eb34ff41aeac4 mpd-svn-20050601.ebuild 3943
MD5 a832e52d5789026d84611787edddf804 mpd-svn-20050408-r1.ebuild 3945
MD5 de1bc8f7789b1ec0f455522f32172bd8 ChangeLog 3537
MD5 28ed49040b6ddc36def2c2a536394b37 metadata.xml 251
+MD5 cec67272ab6c7751858af02d035dbef2 mpd-svn-20050823.ebuild 3861
MD5 c5dbcf547c18db7bc2f46dfcc877190b files/digest-mpd-svn-20050408-r1 69
MD5 4e6ca0e3263baccca8dbe560cb7304da files/mpd.rc6 881
MD5 1e90c2bf70a37aa60def8f6570621667 files/digest-mpd-svn-20050601 69
MD5 f401f6ffc23b28ea41f472eb3d2ef6c0 files/digest-mpd-svn-20050731 69
+MD5 e539ac321bff94e6f20dfe3c4ae41a71 files/digest-mpd-svn-20050823 69
MD5 02158d2f5c411a78b65c7f692fb81405 files/mpd.pidfile.rc6 717
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC6/1kQlM6RnzZP+IRAgB2AJwMeadLPrkon7QuMxvWnoVLh3xrRwCghxCF
-D4WR3WZ8v5u7WSg22pQNQXI=
-=+vlz
------END PGP SIGNATURE-----
diff --git a/media-sound/mpd-svn/files/digest-mpd-svn-20050823 b/media-sound/mpd-svn/files/digest-mpd-svn-20050823
new file mode 100644
index 000000000000..7613bac7294e
--- /dev/null
+++ b/media-sound/mpd-svn/files/digest-mpd-svn-20050823
@@ -0,0 +1 @@
+MD5 1a62de62258db66085bbdc20cc63d9a3 mpd-svn-20050823.tar.bz2 879823
diff --git a/media-sound/mpd-svn/mpd-svn-20050823.ebuild b/media-sound/mpd-svn/mpd-svn-20050823.ebuild
new file mode 100644
index 000000000000..4b426f6d3427
--- /dev/null
+++ b/media-sound/mpd-svn/mpd-svn-20050823.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd-svn/mpd-svn-20050823.ebuild,v 1.1 2005/08/23 15:39:15 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="A development version of Music Player Daemon (mpd)"
+HOMEPAGE="http://www.musicpd.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="aac alsa ao audiofile flac icecast ipv6 mad mikmod musepack ogg unicode"
+
+DEPEND="dev-util/gperf
+ !media-sound/mpd
+ sys-libs/zlib
+ aac? ( >=media-libs/faad2-2.0_rc2 )
+ alsa? ( media-libs/alsa-lib )
+ ao? ( >=media-libs/libao-0.8.4 )
+ audiofile? ( media-libs/audiofile )
+ flac? ( >=media-libs/flac-1.1.0 )
+ icecast? ( media-libs/libshout )
+ mad? ( media-libs/libmad
+ media-libs/libid3tag )
+ mikmod? ( media-libs/libmikmod )
+ musepack? ( >=media-libs/libmusepack-1.1 )
+ ogg? ( media-libs/libogg
+ media-libs/libvorbis )"
+
+pkg_setup() {
+ enewuser mpd '' '' '' audio || die "problem adding user mpd"
+}
+
+src_compile() {
+ econf \
+ $(use_enable aac) \
+ $(use_enable ao) \
+ $(use_enable audiofile) \
+ $(use_enable audiofile audiofiletest) \
+ $(use_enable flac libFLACtest) \
+ $(use_enable flac) \
+ $(use_enable icecast shout) \
+ $(use_enable ipv6) \
+ $(use_enable !mad mpd-mad) \
+ $(use_enable !mad id3tag) \
+ $(use_enable mikmod libmikmodtest) \
+ $(use_enable mikmod mod) \
+ $(use_enable musepack mpc) \
+ $(use_enable ogg) \
+ $(use_enable ogg oggtest) \
+ $(use_enable ogg vorbistest) \
+ || die "could not configure"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /var/run/mpd
+ fowners mpd:audio /var/run/mpd
+ fperms 750 /var/run/mpd
+ keepdir /var/run/mpd
+
+ emake install DESTDIR=${D} || die
+ rm -rf ${D}/usr/share/doc/mpd/
+ dodoc ChangeLog INSTALL README TODO UPGRADING
+ dodoc doc/COMMANDS doc/mpdconf.example
+
+ insinto /etc
+ newins doc/mpdconf.example mpd.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mpd.pidfile.rc6 mpd
+
+ if use unicode; then
+ dosed 's:^#filesystem_charset.*$:filesystem_charset "UTF-8":' /etc/mpd.conf
+ fi
+ dosed 's:^#user.*$:user "mpd":' /etc/mpd.conf
+ dosed 's:^#bind.*$:bind_to_address "localhost":' /etc/mpd.conf
+ dosed 's:^port.*$:port "6600":' /etc/mpd.conf
+ dosed 's:^music_directory.*$:music_directory "/usr/share/mpd/music":' /etc/mpd.conf
+ dosed 's:^playlist_directory.*$:playlist_directory "/usr/share/mpd/playlists":' /etc/mpd.conf
+ dosed 's:^log_file.*$:log_file "/var/log/mpd.log":' /etc/mpd.conf
+ dosed 's:^error_file.*$:error_file "/var/log/mpd.error.log":' /etc/mpd.conf
+ dosed 's:^pid_file.*$:pid_file "/var/run/mpd/mpd.pid":' /etc/mpd.conf
+ diropts -m0755 -o mpd -g audio
+ dodir /usr/share/mpd/music
+ keepdir /usr/share/mpd/music
+ dodir /usr/share/mpd/playlists
+ keepdir /usr/share/mpd/playlists
+ dodir /usr/share/mpd/
+ insinto /var/log
+ touch ${T}/blah
+ insopts -m0640 -o mpd -g audio
+ newins ${T}/blah mpd.log
+ newins ${T}/blah mpd.error.log
+
+ use alsa && \
+ dosed 's:need :need alsasound :' /etc/init.d/mpd
+}
+
+pkg_postinst() {
+ echo
+ einfo "The default config now binds the daemon strictly to localhost,"
+ einfo "rather than to all available IPs."
+ echo
+ if use ao; then
+ einfo "libao prior to 0.8.4 has issues with the ALSA drivers"
+ einfo "please refer to the FAQ"
+ einfo "http://www.musicpd.org/wiki/moin.cgi/MpdFAQ if you are"
+ einfo "having problems."
+ echo
+ else
+ draw_line
+ ewarn "As you're not using libao for audio output, you need to"
+ ewarn "adjust audio_output sections in /etc/mpd.conf to use"
+ ewarn "ALSA or OSS. See"
+ ewarn "/usr/share/doc/${PF}/mpdconf.example.gz."
+ draw_line
+ echo
+ fi
+ einfo "Please make sure that MPD's pid_file is set to /var/run/mpd/mpd.pid."
+ echo
+ ewarn "Note that this is just a development version of Music Player Daemon,"
+ ewarn "so if you want to report any bug to MPD developers, please state this fact in"
+ ewarn "your bug report, as well as the fact that you used a ${P} Gentoo ebuild."
+ echo
+}