summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/chaplin/chaplin-1.10-r1.ebuild')
-rw-r--r--media-video/chaplin/chaplin-1.10-r1.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/media-video/chaplin/chaplin-1.10-r1.ebuild b/media-video/chaplin/chaplin-1.10-r1.ebuild
index 6d743ed90770..d022be24345e 100644
--- a/media-video/chaplin/chaplin-1.10-r1.ebuild
+++ b/media-video/chaplin/chaplin-1.10-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/chaplin/chaplin-1.10-r1.ebuild,v 1.6 2009/12/19 21:59:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/chaplin/chaplin-1.10-r1.ebuild,v 1.7 2011/11/21 21:06:11 radhermit Exp $
-EAPI=2
-inherit eutils
+EAPI=4
+inherit eutils toolchain-funcs
DESCRIPTION="This is a program to raw copy chapters from a dvd using libdvdread"
HOMEPAGE="http://www.lallafa.de/bp/chaplin.html"
@@ -14,8 +14,10 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="transcode vcd"
-DEPEND=">=media-libs/libdvdread-0.9.4
- >=media-gfx/imagemagick-5.5.7.14
+DEPEND=">=media-libs/libdvdread-0.9.4"
+RDEPEND="${DEPEND}
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ media-video/mjpegtools
transcode? ( >=media-video/transcode-0.6.2 )
vcd? ( >=media-video/vcdimager-0.7.2 )"
@@ -26,6 +28,10 @@ src_prepare() {
"${FILESDIR}"/${P}-asneeded.patch
}
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
src_install() {
- dobin chaplin chaplin-genmenu || die
+ dobin chaplin chaplin-genmenu
}