summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/effectv/files/effectv-0.3.10-makefile.patch')
-rw-r--r--media-video/effectv/files/effectv-0.3.10-makefile.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/media-video/effectv/files/effectv-0.3.10-makefile.patch b/media-video/effectv/files/effectv-0.3.10-makefile.patch
new file mode 100644
index 000000000000..33504129050a
--- /dev/null
+++ b/media-video/effectv/files/effectv-0.3.10-makefile.patch
@@ -0,0 +1,19 @@
+Index: effectv-0.3.10/Makefile
+===================================================================
+--- effectv-0.3.10.orig/Makefile
++++ effectv-0.3.10/Makefile
+@@ -40,12 +40,12 @@ all-recursive:
+ all-am: $(PROGRAM)
+
+ $(PROGRAM): $(OBJS) $(LIBEFFECTS) v4lutils/libv4lutils.a
+- $(CC) -o $@ $(OBJS) $(LIBEFFECTS) $(LIBS)
++ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBEFFECTS) $(LIBS)
+
+ $(OBJS): EffecTV.h screen.h video.h palette.h frequencies.h vloopback.h utils.h
+
+ install: all-am
+- $(INSTALL) -s $(PROGRAM) $(bindir)/
++ $(INSTALL) $(PROGRAM) $(bindir)/
+ $(INSTALL) effectv.1 $(mandir)/man1/
+
+ clean: