summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/nvidia-kernel/files/1.0.6106/NVIDIA_kernel-1.0-6106-koutput-support.patch')
-rw-r--r--media-video/nvidia-kernel/files/1.0.6106/NVIDIA_kernel-1.0-6106-koutput-support.patch210
1 files changed, 210 insertions, 0 deletions
diff --git a/media-video/nvidia-kernel/files/1.0.6106/NVIDIA_kernel-1.0-6106-koutput-support.patch b/media-video/nvidia-kernel/files/1.0.6106/NVIDIA_kernel-1.0-6106-koutput-support.patch
new file mode 100644
index 000000000000..d9ce8cee1ef5
--- /dev/null
+++ b/media-video/nvidia-kernel/files/1.0.6106/NVIDIA_kernel-1.0-6106-koutput-support.patch
@@ -0,0 +1,210 @@
+--- Makefile.kbuild.old 2004-07-01 13:54:56.542258768 +1000
++++ Makefile.kbuild 2004-07-01 13:57:04.861751240 +1000
+@@ -93,14 +93,23 @@
+ ifdef SYSSRC
+ KERNEL_SOURCES := $(SYSSRC)
+ KERNEL_HEADERS := $(KERNEL_SOURCES)/include
++ ifdef KVOUT
++ ifneq ($(SYSSRC),$(KVOUT))
++ KOUTPUT_HEADERS := $(KVOUT)/include
++ endif
++ endif
++ ifndef KOUTPUT_HEADERS
++ KOUTPUT_HEADERS := $(KERNEL_HEADERS)
++ endif
+ else
+- KERNEL_UNAME := $(shell uname -r)
+- KERNEL_SOURCES := /lib/modules/$(KERNEL_UNAME)/build
+- KERNEL_HEADERS := $(KERNEL_SOURCES)/include
++ KERNEL_UNAME := $(shell uname -r)
++ KERNEL_SOURCES := /lib/modules/$(KERNEL_UNAME)/build
++ KERNEL_HEADERS := $(KERNEL_SOURCES)/include
++ KOUTPUT_HEADERS := $(KERNEL_HEADERS)
+ endif
+
+ CC ?= gcc
+-CONFTEST := sh $(src)/conftest.sh "$(CC)" $(KERNEL_HEADERS)
++CONFTEST := sh $(src)/conftest.sh "$(CC)" $(KERNEL_HEADERS) $(KOUTPUT_HEADERS)
+
+ KERNEL_UNAME ?= $(shell $(CONFTEST) get_uname)
+ MODULE_ROOT := /lib/modules/$(KERNEL_UNAME)/kernel/drivers
+--- Makefile.nvidia.old 2004-07-01 13:55:03.054268792 +1000
++++ Makefile.nvidia 2004-07-01 13:55:17.799027248 +1000
+@@ -21,6 +21,14 @@
+ ifdef SYSSRC
+ KERNEL_SOURCES := $(SYSSRC)
+ KERNEL_HEADERS := $(KERNEL_SOURCES)/include
++ ifdef KVOUT
++ ifneq ($(SYSSRC),$(KVOUT))
++ KOUTPUT_HEADERS := $(KVOUT)/include
++ endif
++ endif
++ ifndef KOUTPUT_HEADERS
++ KOUTPUT_HEADERS := $(KERNEL_SOURCES)
++ endif
+ else
+ ifdef SYSINCLUDE
+ KERNEL_HEADERS := $(SYSINCLUDE)
+@@ -28,10 +35,11 @@
+ KERNEL_UNAME := $(shell uname -r)
+ KERNEL_HEADERS := /lib/modules/$(KERNEL_UNAME)/build/include
+ endif
++ KOUTPUT_HEADERS := $(KERNEL_SOURCES)
+ endif
+
+ CC ?= cc
+-CONFTEST := sh ./conftest.sh "$(CC)" $(KERNEL_HEADERS)
++CONFTEST := sh ./conftest.sh "$(CC)" $(KERNEL_HEADERS) $(KOUTPUT_HEADERS)
+
+ KERNEL_UNAME ?= $(shell $(CONFTEST) get_uname)
+ MODULE_ROOT := /lib/modules/$(KERNEL_UNAME)/kernel/drivers
+--- makefile.old 2004-07-01 13:54:48.070546664 +1000
++++ makefile 2004-07-01 13:55:13.966609864 +1000
+@@ -11,12 +11,21 @@
+ else
+ KERNEL_HEADERS := /lib/modules/$(shell uname -r)/build/include
+ endif
++ KOUTPUT_HEADERS := $(KERNEL_HEADERS)
+ else
+ KERNEL_HEADERS := $(SYSSRC)/include
++ ifdef KVOUT
++ ifneq ($(SYSSRC),$(KVOUT))
++ KOUTPUT_HEADERS := $(KVOUT)/include
++ endif
++ endif
++ ifndef KOUTPUT_HEADERS
++ KOUTPUT_HEADERS := $(KERNEL_HEADERS)
++ endif
+ endif
+
+ CC ?= cc
+-CONFTEST := sh ./conftest.sh "$(CC)" $(KERNEL_HEADERS)
++CONFTEST := sh ./conftest.sh "$(CC)" $(KERNEL_HEADERS) $(KOUTPUT_HEADERS)
+
+ .PHONY: select_makefile
+ select_makefile:
+--- conftest.sh.old 2004-07-01 13:54:41.750507456 +1000
++++ conftest.sh 2004-07-01 13:55:08.910378528 +1000
+@@ -7,16 +7,18 @@
+
+ CC="$1"
+ ISYSTEM=`$CC -print-file-name=include`
+-HEADERS=$2
++SOURCE_HEADERS=$2
++BUILT_HEADERS=$3
+
+ CFLAGS="-D__KERNEL__ \
+ -Werror \
+ -nostdinc \
+ -isystem $ISYSTEM \
+--I $HEADERS -I $HEADERS/asm/mach-default \
++-I $SOURCE_HEADERS -I $SOURCE_HEADERS/asm/mach-default \
++-I $BUILT_HEADERS -I $BUILT_HEADERS/../include2/asm/mach-default \
+ -Wimplicit-function-declaration"
+
+-case "$3" in
++case "$4" in
+ remap_page_range)
+ #
+ # Determine the number of arguments expected by remap_page_range.
+@@ -124,7 +126,7 @@
+ # Determine the kernel's major patch level; this is only done if we
+ # aren't told by KBUILD.
+ #
+- SOURCES=$HEADERS/..
++ SOURCES=$SOURCE_HEADERS/..
+
+ echo $(grep "^PATCHLEVEL =" $SOURCES/Makefile | cut -d " " -f 3)
+ exit 0
+@@ -193,7 +195,7 @@
+ RET=1
+ OUTPUT=$4
+
+- if [ -f $HEADERS/linux/version.h ]; then
++ if [ -f $BUILT_HEADERS/linux/version.h ]; then
+ #
+ # We are either looking at a configured kernel source
+ # tree or at headers shipped for a specific kernel.
+@@ -208,7 +210,7 @@
+ }
+ }" > conftest$$.c
+
+- $CC conftest$$.c -o conftest$$ -nostdinc -I $HEADERS > /dev/null 2>&1
++ $CC conftest$$.c -o conftest$$ -nostdinc -I $BUILT_HEADERS > /dev/null 2>&1
+ rm -f conftest$$.c
+
+ if [ -f conftest$$ ]; then
+@@ -222,8 +224,8 @@
+ RET=0
+ fi
+ else
+- MAKEFILE=$HEADERS/../Makefile
+- CONFIG=$HEADERS/../.config
++ MAKEFILE=$SOURCE_HEADERS/../Makefile
++ CONFIG=$BUILT_HEADERS/../.config
+
+ if [ -f $MAKEFILE -a -f $CONFIG ]; then
+ #
+@@ -275,7 +277,7 @@
+ return 0;
+ }" > conftest$$.c
+
+- $CC conftest$$.c -o conftest$$ -nostdinc -I $HEADERS > /dev/null 2>&1
++ $CC conftest$$.c -o conftest$$ -nostdinc -I $BUILT_HEADERS > /dev/null 2>&1
+ rm -f conftest$$.c
+
+ if [ -f conftest$$ ]; then
+@@ -296,7 +298,7 @@
+ RET=1
+ OUTPUT=$4
+
+- if [ -f $HEADERS/linux/autoconf.h ]; then
++ if [ -f $BUILT_HEADERS/linux/autoconf.h ]; then
+ #
+ # We are looking at a configured source tree; verify
+ # that its configuration doesn't include rivafb using
+@@ -308,7 +310,7 @@
+ #endif
+ " > conftest$$.c
+
+- $CC -c conftest$$.c -nostdinc -I $HEADERS > /dev/null 2>&1
++ $CC -c conftest$$.c -nostdinc -I $BUILT_HEADERS > /dev/null 2>&1
+ rm -f conftest$$.c
+
+ if [ -f conftest$$.o ]; then
+@@ -316,7 +318,7 @@
+ RET=0
+ fi
+ else
+- CONFIG=$HEADERS/../.config
++ CONFIG=$BUILT_HEADERS/../.config
+ if [ -f $CONFIG ]; then
+ if [ -z "$(grep "^CONFIG_FB_RIVA=y" $CONFIG)" ]; then
+ RET=0
+@@ -352,7 +354,7 @@
+ RET=1
+ OUTPUT=$4
+
+- if [ -f $HEADERS/linux/autoconf.h ]; then
++ if [ -f $BUILT_HEADERS/linux/autoconf.h ]; then
+ #
+ # We are looking at a configured source tree; verify
+ # that its configuration doesn't include rivafb using
+@@ -364,7 +366,7 @@
+ #endif
+ " > conftest$$.c
+
+- $CC -c conftest$$.c -nostdinc -I $HEADERS > /dev/null 2>&1
++ $CC -c conftest$$.c -nostdinc -I $BUILT_HEADERS > /dev/null 2>&1
+ rm -f conftest$$.c
+
+ if [ -f conftest$$.o ]; then
+@@ -372,7 +374,7 @@
+ RET=0
+ fi
+ else
+- CONFIG=$HEADERS/../.config
++ CONFIG=$BUILT_HEADERS/../.config
+ if [ -f $CONFIG ]; then
+ if [ -z "$(grep "^CONFIG_FB_RIVA=m" $CONFIG)" ]; then
+ RET=0