summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagstamon/files')
-rw-r--r--net-analyzer/nagstamon/files/nagstamon-0.9.10_p20130222.patch73
-rw-r--r--net-analyzer/nagstamon/files/nagstamon-0.9.9-icinga_results_limitations.patch31
-rw-r--r--net-analyzer/nagstamon/files/nagstamon-0.9.9-resources.patch33
-rw-r--r--net-analyzer/nagstamon/files/nagstamon.desktop3
4 files changed, 1 insertions, 139 deletions
diff --git a/net-analyzer/nagstamon/files/nagstamon-0.9.10_p20130222.patch b/net-analyzer/nagstamon/files/nagstamon-0.9.10_p20130222.patch
deleted file mode 100644
index ca97c101d7cc..000000000000
--- a/net-analyzer/nagstamon/files/nagstamon-0.9.10_p20130222.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From a0c44eac2a152291e2ce04bb7c320da896c77af2 Mon Sep 17 00:00:00 2001
-From: Christian Ruppert <idl0r@gentoo.org>
-Date: Tue, 26 Feb 2013 22:59:21 +0100
-Subject: [PATCH] Fix BeautifulSoup import
-
-
-Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
----
- Nagstamon/Nagstamon/Server/Ninja.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Nagstamon/Nagstamon/Server/Ninja.py b/Nagstamon/Nagstamon/Server/Ninja.py
-index dd53cbe..4cee123 100644
---- a/Nagstamon/Nagstamon/Server/Ninja.py
-+++ b/Nagstamon/Nagstamon/Server/Ninja.py
-@@ -13,7 +13,7 @@ import cookielib
- from Nagstamon import Actions
- from Nagstamon.Objects import *
- from Nagstamon.Server.Generic import GenericServer, not_empty
--from Nagstamon.BeautifulSoup import BeautifulSoup
-+from BeautifulSoup import BeautifulSoup
-
- class NinjaServer(GenericServer):
- """
---
-1.7.12.4
-
-diff --git a/Nagstamon/nagstamon.py b/Nagstamon/nagstamon.py
-index 2206db5..66da87e 100755
---- a/Nagstamon/nagstamon.py
-+++ b/Nagstamon/nagstamon.py
-@@ -33,40 +33,7 @@ conf.Convert_Conf_to_Multiple_Servers()
- conf.Convert_Conf_to_Custom_Actions()
-
- # try to get resources path if nagstamon got be installed by setup.py
--Resources = ""
--try:
-- import pkg_resources
-- Resources = pkg_resources.resource_filename("Nagstamon", "resources")
--except Exception, err:
-- # get resources directory from current directory - only if not being set before by pkg_resources
-- # try-excepts necessary for platforms like Windows .EXE
-- join = os.path.join
-- normcase = os.path.normcase
-- paths_to_check = [normcase(join(os.getcwd(), "Nagstamon", "resources")),
-- normcase(join(os.getcwd(), "resources"))]
-- try:
-- # if resources dir is not available in CWD, try the
-- # libs dir (site-packages) for the current Python
-- from distutils.sysconfig import get_python_lib
-- paths_to_check.append(normcase(join(get_python_lib(), "Nagstamon", "resources")))
-- except:
-- pass
--
-- #if we're still out of luck, maybe this was a user scheme install
-- try:
-- import site
-- site.getusersitepackages() #make sure USER_SITE is set
-- paths_to_check.append(normcase(join(site.USER_SITE, "Nagstamon", "resources")))
-- except:
-- pass
--
-- # add directory nagstamon.py where nagstamon.py resides for cases like 0install without installed pkg-resources
-- paths_to_check.append(os.sep.join(sys.argv[0].split(os.sep)[:-1] + ["Nagstamon", "resources"]))
--
-- for path in paths_to_check:
-- if os.path.exists(path):
-- Resources = path
-- break
-+Resources = "/usr/share/nagstamon/resources"
-
- # initialize GUI and actions
- # if modules are not available from central python install try the ones in the same directory
diff --git a/net-analyzer/nagstamon/files/nagstamon-0.9.9-icinga_results_limitations.patch b/net-analyzer/nagstamon/files/nagstamon-0.9.9-icinga_results_limitations.patch
deleted file mode 100644
index 986ec51014b5..000000000000
--- a/net-analyzer/nagstamon/files/nagstamon-0.9.9-icinga_results_limitations.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 61928eea1075f22be24c4122c66ff7c2a1dcefae Mon Sep 17 00:00:00 2001
-From: Christian Ruppert <idl0r@gentoo.org>
-Date: Mon, 25 Feb 2013 01:33:10 +0100
-Subject: [PATCH] Fix Icinga's default result limitations,
- https://github.com/HenriWahl/Nagstamon/issues/10
-
-
-Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
----
- Nagstamon/Server/Generic.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Nagstamon/Server/Generic.py b/Nagstamon/Server/Generic.py
-index 0dfd1d6..cfe613d 100644
---- a/Nagstamon/Server/Generic.py
-+++ b/Nagstamon/Server/Generic.py
-@@ -434,9 +434,9 @@ class GenericServer(object):
- # group them together
- hostserviceprops = 0
- # services (unknown, warning or critical?)
-- nagcgiurl_services = self.monitor_cgi_url + "/status.cgi?host=all&servicestatustypes=" + str(servicestatustypes) + "&serviceprops=" + str(hostserviceprops)
-+ nagcgiurl_services = self.monitor_cgi_url + "/status.cgi?host=all&limit=0&servicestatustypes=" + str(servicestatustypes) + "&serviceprops=" + str(hostserviceprops)
- # hosts (up or down or unreachable)
-- nagcgiurl_hosts = self.monitor_cgi_url + "/status.cgi?hostgroup=all&style=hostdetail&hoststatustypes=" + str(hoststatustypes) + "&hostprops=" + str(hostserviceprops)
-+ nagcgiurl_hosts = self.monitor_cgi_url + "/status.cgi?hostgroup=all&limit=0&style=hostdetail&hoststatustypes=" + str(hoststatustypes) + "&hostprops=" + str(hostserviceprops)
- # hosts - mostly the down ones
- # unfortunately the hosts status page has a different structure so
- # hosts must be analyzed separately
---
-1.7.12.4
-
diff --git a/net-analyzer/nagstamon/files/nagstamon-0.9.9-resources.patch b/net-analyzer/nagstamon/files/nagstamon-0.9.9-resources.patch
deleted file mode 100644
index c5f709f05690..000000000000
--- a/net-analyzer/nagstamon/files/nagstamon-0.9.9-resources.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/nagstamon.py b/nagstamon.py
-index 5d61ef8..0a4db87 100755
---- a/nagstamon.py
-+++ b/nagstamon.py
-@@ -35,17 +35,17 @@ conf.Convert_Conf_to_Multiple_Servers()
- conf.Convert_Conf_to_Custom_Actions()
-
- # try to get resources path if nagstamon got be installed by setup.py
--Resources = ""
--try:
-- import pkg_resources
-- Resources = pkg_resources.resource_filename("Nagstamon", "resources")
--except Exception, err:
-- # get resources directory from current directory - only if not being set before by pkg_resources
-- if Resources == "":
-- if os.path.exists(os.path.normcase(os.getcwd() + os.sep + "Nagstamon" + os.sep + "resources")):
-- Resources = os.path.normcase(os.getcwd() + os.sep + "Nagstamon" + os.sep + "resources")
-- else:
-- Resources = os.path.normcase(os.getcwd() + os.sep + "resources")
-+Resources = "/usr/share/nagstamon/resources"
-+#try:
-+# import pkg_resources
-+# Resources = pkg_resources.resource_filename("Nagstamon", "resources")
-+#except Exception, err:
-+# # get resources directory from current directory - only if not being set before by pkg_resources
-+# if Resources == "":
-+# if os.path.exists(os.path.normcase(os.getcwd() + os.sep + "Nagstamon" + os.sep + "resources")):
-+# Resources = os.path.normcase(os.getcwd() + os.sep + "Nagstamon" + os.sep + "resources")
-+# else:
-+# Resources = os.path.normcase(os.getcwd() + os.sep + "resources")
-
- # initialize GUI and actions
- # if modules are not available from central python install try the ones in the same directory
diff --git a/net-analyzer/nagstamon/files/nagstamon.desktop b/net-analyzer/nagstamon/files/nagstamon.desktop
index 2875a72ac5ae..d853e1aae7ba 100644
--- a/net-analyzer/nagstamon/files/nagstamon.desktop
+++ b/net-analyzer/nagstamon/files/nagstamon.desktop
@@ -1,6 +1,5 @@
[Desktop Entry]
Version=1.0
-Encoding=UTF-8
Type=Application
Name=Nagstamon
GenericName=Nagios status monitor
@@ -8,5 +7,5 @@ Comment=Quick status overview of your Nagios monitoring system
Exec=nagstamon
Icon=/usr/share/nagstamon/resources/nagstamon.png
Terminal=false
-Categories=Application;System;
+Categories=Network;Monitor;
StartupNotify=true