summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/net-snmp/net-snmp-5.5.ebuild')
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.5.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-analyzer/net-snmp/net-snmp-5.5.ebuild b/net-analyzer/net-snmp/net-snmp-5.5.ebuild
index 001e153d17ae..b716a5672144 100644
--- a/net-analyzer/net-snmp/net-snmp-5.5.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.5.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.5.ebuild,v 1.4 2011/02/26 19:15:45 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.5.ebuild,v 1.5 2011/03/01 20:02:12 arfrever Exp $
EAPI="3"
+PYTHON_DEPEND="python? 2"
inherit fixheadtails flag-o-matic perl-module python
@@ -41,6 +42,13 @@ DEPEND="${COMMON}
>=sys-apps/sed-4
doc? ( app-doc/doxygen )"
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
# fix access violation in make check
sed -i \