summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nikto')
-rw-r--r--net-analyzer/nikto/ChangeLog11
-rw-r--r--net-analyzer/nikto/Manifest5
-rw-r--r--net-analyzer/nikto/files/digest-nikto-1.311
-rw-r--r--net-analyzer/nikto/metadata.xml10
-rw-r--r--net-analyzer/nikto/nikto-1.31.ebuild52
5 files changed, 77 insertions, 2 deletions
diff --git a/net-analyzer/nikto/ChangeLog b/net-analyzer/nikto/ChangeLog
new file mode 100644
index 000000000000..61c0ea821341
--- /dev/null
+++ b/net-analyzer/nikto/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-analyzer/nikto
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/ChangeLog,v 1.1 2003/10/06 12:06:56 mcummings Exp $
+
+*nikto-1.31 (06 Oct 2003)
+
+ 06 Oct 2003; Michael Cummings <mcummings@gentoo.org> metadata.xml,
+ nikto-1.31.ebuild:
+ Bug 12116; original ebuild submitted by Marlon Jabbur <mjabbur@terra.com.br>;
+ edited to meet requirements of new/current version of nikto.
+
diff --git a/net-analyzer/nikto/Manifest b/net-analyzer/nikto/Manifest
index 5a70d7347ee8..21cec13ff063 100644
--- a/net-analyzer/nikto/Manifest
+++ b/net-analyzer/nikto/Manifest
@@ -1,3 +1,4 @@
-MD5 630e1f9cd1b3cc98d1cff25e105c8e59 Changelog 230
-MD5 cbcd2c15599e68b2305a09258aae1c41 nikto-1.31.ebuild 1412
+MD5 a9e0615ff2255ce481b0e66b8c8ad817 nikto-1.31.ebuild 1396
+MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
+MD5 f280afc9387d2207ee1d4fb15b9f2ef4 ChangeLog 477
MD5 4fd028ff30a713c4de5e0e295c8e09c8 files/digest-nikto-1.31 62
diff --git a/net-analyzer/nikto/files/digest-nikto-1.31 b/net-analyzer/nikto/files/digest-nikto-1.31
new file mode 100644
index 000000000000..9b5358c320e1
--- /dev/null
+++ b/net-analyzer/nikto/files/digest-nikto-1.31
@@ -0,0 +1 @@
+MD5 cb6719d7e0fd4659cb826f821f01cd64 nikto-1.31.tar.gz 166796
diff --git a/net-analyzer/nikto/metadata.xml b/net-analyzer/nikto/metadata.xml
new file mode 100644
index 000000000000..86672fe64c10
--- /dev/null
+++ b/net-analyzer/nikto/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription></longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/nikto/nikto-1.31.ebuild b/net-analyzer/nikto/nikto-1.31.ebuild
new file mode 100644
index 000000000000..ff56231be410
--- /dev/null
+++ b/net-analyzer/nikto/nikto-1.31.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/nikto-1.31.ebuild,v 1.1 2003/10/06 12:06:56 mcummings Exp $
+
+DESCRIPTION="Web Server vulnerability scanner."
+HOMEPAGE="http://www.cirt.net/code/nikto.shtml"
+SRC_URI="http://www.cirt.net/source/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+DEPEND=">=perl-5.6.1
+ >=libwhisker-1.5
+ >=nmap-3.00
+ ssl? ( dev-libs/openssl ) "
+RDEPEND=${DEPEND}
+IUSE=""
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ einfo ${WORKDIR}
+ cd ${S}
+ sed -i -e 's:config.txt:nikto.conf:' \
+ -i -e 's:\$CFG{configfile}="nikto.conf":\$CFG{configfile}="/etc/nikto/nikto.conf":' \
+ nikto.pl
+ mv config.txt nikto.conf
+ sed -i -e 's:^#NMAP:NMAP:' \
+ -i -e 's:^PROXYHOST:#PROXYHOST:' \
+ -i -e 's:^PROXYPORT:#PROXYPORT:' \
+ -i -e 's:^PROXYUSER:#PROXYUSER:' \
+ -i -e 's:^PROXYPASS:#PROXYPASS:' \
+ -i -e 's:# PLUGINDIR=/usr/local/nikto/plugins:PLUGINDIR=/usr/share/nikto/plugins:' \
+ nikto.conf
+}
+
+src_install() {
+ cd ${S}
+ insinto /etc/nikto
+ doins nikto.conf
+ cd docs
+ dodoc CHANGES.txt LICENSE.txt README_plugins.txt nikto_usage.txt
+ dohtml nikto_usage.html
+ cd ..
+ dodir /usr/bin
+ dobin nikto.pl
+ dosym /usr/bin/nikto.pl /usr/bin/nikto
+ dodir /usr/share/nikto/plugins
+ insinto /usr/share/nikto/plugins
+ cd plugins
+ doins *
+}