summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/postal')
-rw-r--r--net-analyzer/postal/ChangeLog11
-rw-r--r--net-analyzer/postal/Manifest3
-rw-r--r--net-analyzer/postal/postal-0.62.ebuild15
3 files changed, 23 insertions, 6 deletions
diff --git a/net-analyzer/postal/ChangeLog b/net-analyzer/postal/ChangeLog
index 55a8c1ef5d6f..b39c235554b9 100644
--- a/net-analyzer/postal/ChangeLog
+++ b/net-analyzer/postal/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-analyzer/postal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/postal/ChangeLog,v 1.1 2005/01/08 00:35:45 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/postal/ChangeLog,v 1.1.1.1 2005/11/30 10:12:25 chriswhite Exp $
+
+ 17 Mar 2005; Michael Hanselmann <hansmi@gentoo.org> postal-0.62.ebuild:
+ Added to ~hppa, stable on ppc.
+
+ 08 Jan 2005; Michael Hanselmann <hansmi@gentoo.org> postal-0.62.ebuild:
+ Fixed not working use_enable because of a broken configure script.
+
+ 08 Jan 2005; Sven Wegener <swegener@gentoo.org> postal-0.62.ebuild:
+ Fixed invalid atoms in *DEPEND.
*postal-0.62 (08 Jan 2005)
diff --git a/net-analyzer/postal/Manifest b/net-analyzer/postal/Manifest
index d55c29d80522..a3022cebadac 100644
--- a/net-analyzer/postal/Manifest
+++ b/net-analyzer/postal/Manifest
@@ -1,3 +1,4 @@
-MD5 b8f1a7c574cb5e6e9051efe37683ba5a postal-0.62.ebuild 584
+MD5 5428bb2d2cb90c8d088528b85019c0bf postal-0.62.ebuild 811
MD5 2169405288c432c981b23bc7965d15c9 metadata.xml 162
+MD5 579f933aa680c2edbb44b4626f13f8b1 ChangeLog 743
MD5 a58939d8e822b8c41dbd21436b29552f files/digest-postal-0.62 59
diff --git a/net-analyzer/postal/postal-0.62.ebuild b/net-analyzer/postal/postal-0.62.ebuild
index 83c127864cef..49104e329246 100644
--- a/net-analyzer/postal/postal-0.62.ebuild
+++ b/net-analyzer/postal/postal-0.62.ebuild
@@ -1,18 +1,25 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/postal/postal-0.62.ebuild,v 1.1 2005/01/08 00:35:45 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/postal/postal-0.62.ebuild,v 1.1.1.1 2005/11/30 10:12:25 chriswhite Exp $
DESCRIPTION="SMTP and POP mailserver benchmark - the mad postman. Supports SSL, randomized user accounts and more."
HOMEPAGE="http://www.coker.com.au/postal/"
SRC_URI="http://www.coker.com.au/postal/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc"
+KEYWORDS="~x86 ~sparc ppc ~hppa"
IUSE="ssl"
-DEPEND="ssl? ( >=openssl-0.9.6b )"
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
src_compile() {
- econf `use_enable ssl`
+ myconf=
+
+ if use !ssl; then
+ # broken configure, use_enable doesn't work right
+ myconf="${myconf} --disable-ssl"
+ fi
+
+ econf ${myconf} || die
emake || die
}