summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/sarg')
-rw-r--r--net-analyzer/sarg/sarg-2.2.5.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/net-analyzer/sarg/sarg-2.2.5.ebuild b/net-analyzer/sarg/sarg-2.2.5.ebuild
index a814f1cccf80..fc93eb043632 100644
--- a/net-analyzer/sarg/sarg-2.2.5.ebuild
+++ b/net-analyzer/sarg/sarg-2.2.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-2.2.5.ebuild,v 1.4 2008/03/10 07:58:45 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-2.2.5.ebuild,v 1.5 2009/03/08 11:03:33 cla Exp $
+
+EAPI="2"
inherit eutils
@@ -14,12 +16,7 @@ KEYWORDS="amd64 ppc x86"
SLOT="0"
IUSE=""
-DEPEND="media-libs/gd"
-
-pkg_setup() {
- built_with_use -a media-libs/gd png || die \
- "Please recompile media-libs/gd with USE=\"png\""
-}
+DEPEND="media-libs/gd[png]"
src_unpack() {
unpack ${A}
@@ -48,13 +45,11 @@ src_unpack() {
sarg.1 || die "Failed to fix man page."
}
-src_compile() {
+src_configure() {
econf \
--enable-bindir=/usr/bin \
--enable-mandir=/usr/share/man/man1 \
--enable-sysconfdir=/etc/sarg/ || die "econf failed"
-
- emake || die "emake failed"
}
src_install() {