summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lftp/lftp-4.4.0.ebuild')
-rw-r--r--net-ftp/lftp/lftp-4.4.0.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/net-ftp/lftp/lftp-4.4.0.ebuild b/net-ftp/lftp/lftp-4.4.0.ebuild
index aaa49fa6cbfb..cdebc96e71de 100644
--- a/net-ftp/lftp/lftp-4.4.0.ebuild
+++ b/net-ftp/lftp/lftp-4.4.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.4.0.ebuild,v 1.6 2012/12/16 17:50:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.4.0.ebuild,v 1.7 2012/12/17 11:55:25 jer Exp $
EAPI=4
-inherit autotools eutils
+inherit autotools eutils libtool
DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
HOMEPAGE="http://lftp.yar.ru/"
@@ -11,7 +11,7 @@ SRC_URI="http://ftp.yars.free.net/pub/source/${PN}/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
LFTP_LINGUAS="cs de es fr it ja ko pl pt_BR ru zh_CN zh_HK zh_TW"
@@ -38,8 +38,8 @@ DEPEND="
=sys-devel/libtool-2*
app-arch/xz-utils
dev-lang/perl
- virtual/pkgconfig
nls? ( sys-devel/gettext )
+ virtual/pkgconfig
"
DOCS=(
@@ -53,6 +53,7 @@ src_prepare() {
"${FILESDIR}/${PN}-4.3.5-autopoint.patch" \
"${FILESDIR}/${PN}-4.3.8-gets.patch"
eautoreconf
+ elibtoolize # for Darwin bundles
}
src_configure() {
@@ -61,18 +62,18 @@ src_configure() {
if use ssl && use gnutls ; then
myconf="${myconf} --without-openssl"
elif use ssl && ! use gnutls ; then
- myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ myconf="${myconf} --without-gnutls --with-openssl=${EPREFIX}/usr"
else
myconf="${myconf} --without-gnutls --without-openssl"
fi
- use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ use socks5 && myconf="${myconf} --with-socksdante=${EPREFIX}/usr" \
|| myconf="${myconf} --without-socksdante"
econf \
- --enable-packager-mode \
- --sysconfdir=/etc/lftp \
- --with-modules \
$(use_enable nls) \
- ${myconf}
+ ${myconf} \
+ --enable-packager-mode \
+ --sysconfdir="${EPREFIX}"/etc/lftp \
+ --with-modules
}