summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/oftpd/oftpd-0.3.6-r7.ebuild')
-rw-r--r--net-ftp/oftpd/oftpd-0.3.6-r7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-ftp/oftpd/oftpd-0.3.6-r7.ebuild b/net-ftp/oftpd/oftpd-0.3.6-r7.ebuild
new file mode 100644
index 000000000000..c1e7d30ef77a
--- /dev/null
+++ b/net-ftp/oftpd/oftpd-0.3.6-r7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/oftpd/oftpd-0.3.6-r7.ebuild,v 1.1 2002/05/04 03:42:50 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Secure, small, anonymous only ftpd"
+SRC_URI="http://www.time-travellers.org/oftpd/${P}.tar.gz"
+HOMEPAGE="http://www.time-travellers.org/oftpd"
+
+DEPEND="virtual/glibc"
+LICENSE="as-is"
+SLOT="0"
+
+src_compile() {
+ # local myconf
+ # ipv6 support busted according to lamer
+ # use ipv6 && myconf="${myconf} --enable-ipv6"
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/sbin \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS COPYING INSTALL FAQ NEWS README TODO
+ dodir /home/ftp
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/oftpd.rc6 oftpd
+}