summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/netembryo/netembryo-0.1.1.ebuild')
-rw-r--r--net-libs/netembryo/netembryo-0.1.1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/net-libs/netembryo/netembryo-0.1.1.ebuild b/net-libs/netembryo/netembryo-0.1.1.ebuild
index 554b8ee09542..2175d4996269 100644
--- a/net-libs/netembryo/netembryo-0.1.1.ebuild
+++ b/net-libs/netembryo/netembryo-0.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/netembryo/netembryo-0.1.1.ebuild,v 1.1 2009/10/27 12:11:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/netembryo/netembryo-0.1.1.ebuild,v 1.2 2009/10/27 12:33:28 ssuominen Exp $
EAPI=2
inherit multilib
@@ -12,24 +12,22 @@ SRC_URI="http://lscube.org/files/downloads/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ipv6 test"
-# sctp
+IUSE="ipv6 +sctp test"
-RDEPEND=">=dev-libs/openssl-0.9.8"
+RDEPEND=">=dev-libs/openssl-0.9.8
+ sctp? ( net-misc/lksctp-tools )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
test? ( >=dev-libs/glib-2.20:2
sys-apps/gawk
dev-util/ctags )"
-# $(use_enable sctp)
-# http://lksctp.sourceforge.net/
src_configure() {
econf \
--disable-dependency-tracking \
--disable-static \
$(use_enable ipv6) \
- --disable-sctp \
+ $(use_enable sctp) \
$(use_enable test tests)
}