summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/pam_ldap')
-rw-r--r--net-libs/pam_ldap/ChangeLog7
-rw-r--r--net-libs/pam_ldap/files/digest-pam_ldap-1561
-rw-r--r--net-libs/pam_ldap/pam_ldap-156.ebuild44
3 files changed, 51 insertions, 1 deletions
diff --git a/net-libs/pam_ldap/ChangeLog b/net-libs/pam_ldap/ChangeLog
index ed09c14dcb33..63d13d864278 100644
--- a/net-libs/pam_ldap/ChangeLog
+++ b/net-libs/pam_ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/pam_ldap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-libs/pam_ldap/ChangeLog,v 1.2 2002/04/20 23:03:48 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pam_ldap/ChangeLog,v 1.3 2002/10/30 22:20:07 aliz Exp $
+
+*pam_ldap-156 (30 Oct 2002)
+
+ 30 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update.
*pam_ldap-134-r1 (18 Apr 2002)
diff --git a/net-libs/pam_ldap/files/digest-pam_ldap-156 b/net-libs/pam_ldap/files/digest-pam_ldap-156
new file mode 100644
index 000000000000..9cfd4a5f0d8a
--- /dev/null
+++ b/net-libs/pam_ldap/files/digest-pam_ldap-156
@@ -0,0 +1 @@
+MD5 02ca2eb266513c61027d168e12e3eb3c pam_ldap-156.tar.gz 115648
diff --git a/net-libs/pam_ldap/pam_ldap-156.ebuild b/net-libs/pam_ldap/pam_ldap-156.ebuild
new file mode 100644
index 000000000000..e2a7df7facfa
--- /dev/null
+++ b/net-libs/pam_ldap/pam_ldap-156.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pam_ldap/pam_ldap-156.ebuild,v 1.1 2002/10/30 22:20:07 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/pam_ldap.html"
+SRC_URI="ftp://ftp.padl.com/pub/${P}.tar.gz"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=net-nds/openldap-1.2.11"
+
+SLOT="0"
+LICENSE="GPL-2 | LGPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+src_compile() {
+ aclocal
+ autoconf
+ automake --add-missing
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-ldap-lib=openldap || die
+
+ emake || die
+}
+
+src_install() {
+
+ exeinto /lib/security
+ doexe pam_ldap.so
+
+ dodoc pam.conf ldap.conf
+ dodoc ChangeLog COPYING.* CVSVersionInfo.txt README
+ docinto pam.d
+ dodoc pam.d/*
+}
+