summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/qxmpp/qxmpp-9999.ebuild')
-rw-r--r--net-libs/qxmpp/qxmpp-9999.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/net-libs/qxmpp/qxmpp-9999.ebuild b/net-libs/qxmpp/qxmpp-9999.ebuild
index 4105da5d23ba..23535da301fc 100644
--- a/net-libs/qxmpp/qxmpp-9999.ebuild
+++ b/net-libs/qxmpp/qxmpp-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/qxmpp/qxmpp-9999.ebuild,v 1.6 2012/10/01 19:52:08 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/qxmpp/qxmpp-9999.ebuild,v 1.7 2012/10/04 15:19:59 pinkbyte Exp $
EAPI=4
@@ -14,19 +14,31 @@ HOMEPAGE="http://code.google.com/p/qxmpp/"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS=""
-IUSE="debug"
+IUSE="debug doc"
DEPEND="x11-libs/qt-core:4
x11-libs/qt-gui:4
media-libs/speex"
RDEPEND="${DEPEND}"
+src_prepare(){
+ if ! use doc; then
+ sed -i \
+ -e '/SUBDIRS/s/doc//' \
+ -e '/INSTALLS/d' \
+ qxmpp.pro || die "sed for removing docs failed"
+ fi
+ qt4-r2_src_prepare
+}
+
src_configure(){
eqmake4 "${S}"/qxmpp.pro "PREFIX=/usr" "LIBDIR=$(get_libdir)"
}
src_install() {
qt4-r2_src_install
- # Use proper path for documentation
- mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${P} || die "doc mv failed"
+ if use doc; then
+ # Use proper path for documentation
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${P} || die "doc mv failed"
+ fi
}