summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild')
-rw-r--r--net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild b/net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..473160bdc763
--- /dev/null
+++ b/net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild,v 1.1 2005/01/13 15:14:51 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="Hotmail to pop3 daemon"
+HOMEPAGE="http://hotwayd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hotwayd/${P}.tar.bz2"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+
+IUSE="smtp"
+
+DEPEND="virtual/inetd
+ dev-libs/libxml2
+ smtp? ( >=dev-libs/cyrus-sasl-2 )"
+
+src_install () {
+ # The original make install is broken, since it also tries to install
+ # the libghttp files. This is not needed, since this library is statically
+ # linked into the executable.
+ # Lets just copy the (one) file manually...
+ dosbin hotwayd
+ if use smtp; then
+ dosbin hotsmtpd/hotsmtpd
+ insinto /etc/xinetd.d
+ newins hotsmtpd/hotsmtpd.xinetd hotsmtpd
+ fi
+
+ dodoc AUTHORS NEWS README
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/${PN}.xinetd ${PN}
+}
+
+pkg_postinst () {
+ einfo ""
+ einfo " By default daemons that use xinetd are not started "
+ einfo " automatically in gentoo"
+ einfo " To activate do the following steps: "
+ einfo " - Edit the file /etc/xinetd.d/hotwayd and change disable "
+ einfo " from yes to no "
+ einfo " - Add the following line to /etc/services: "
+ einfo " hotwayd 110/tcp "
+ einfo " - Note: if you already have a daemon serving port 110 (the "
+ einfo " default pop3 port); then change the port number to something "
+ einfo " else; also change the port number in hotwayd "
+ einfo " - If you already had xinetd up and running, restart with "
+ einfo " # /etc/init.d/xinetd restart "
+ einfo " or "
+ einfo " If the emerge also pulled in the xinetd package for you, do "
+ einfo " # rc-update add xinetd default "
+ einfo " # /etc/init.d/xinetd start "
+ einfo ""
+ if use smtp; then
+ einfo "You chose to install hotsmtpd, a SMTP proxy for hotmail. Please"
+ einfo "Configure /etc/xinetd.d/hotsmtpd and restart xinetd to start using it."
+ fi
+}