summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/oidentd/oidentd-2.0.8.ebuild')
-rw-r--r--net-misc/oidentd/oidentd-2.0.8.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/net-misc/oidentd/oidentd-2.0.8.ebuild b/net-misc/oidentd/oidentd-2.0.8.ebuild
index d4e4b73a1d3b..07852aa66398 100644
--- a/net-misc/oidentd/oidentd-2.0.8.ebuild
+++ b/net-misc/oidentd/oidentd-2.0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/oidentd/oidentd-2.0.8.ebuild,v 1.2 2006/09/29 23:19:19 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/oidentd/oidentd-2.0.8.ebuild,v 1.3 2007/04/22 16:49:15 phreak Exp $
DESCRIPTION="Another (RFC1413 compliant) ident daemon"
HOMEPAGE="http://dev.ojnk.net/"
@@ -11,24 +11,26 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
IUSE="ipv6"
-DEPEND="virtual/libc"
+DEPEND=""
+RDEPEND=""
src_compile() {
- econf $(use_enable ipv6) || die "econf failed"
- emake || die "emake failed"
+ econf $( use_enable ipv6 ) || die "econf failed!"
+ emake || die "emake failed!"
}
src_install() {
- emake DESTDIR=${D} install || die "Install failed"
+ make DESTDIR="${D}" install || die "make install failed!"
dodoc AUTHORS ChangeLog README TODO NEWS \
- ${FILESDIR}/oidentd_masq.conf ${FILESDIR}/oidentd.conf
-
- newinitd ${FILESDIR}/${PN}-2.0.7-init ${PN} || die "newinitd failed"
- newconfd ${FILESDIR}/${PN}-2.0.7-confd ${PN} || die "newconfd failed"
+ "${FILESDIR}"/${PN}_masq.conf "${FILESDIR}"/${PN}.conf
+ newinitd "${FILESDIR}"/oidentd-${PV}-init ${PN}
+ newconfd "${FILESDIR}"/oidentd-${PV}-confd ${PN}
}
pkg_postinst() {
- einfo "Example configuration files are in /usr/share/doc/${PF}"
+ echo
+ elog "Example configuration files are in /usr/share/doc/${PF}"
+ echo
}