summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openvpn/openvpn-1.3.2-r1.ebuild')
-rw-r--r--net-misc/openvpn/openvpn-1.3.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/openvpn/openvpn-1.3.2-r1.ebuild b/net-misc/openvpn/openvpn-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..f3596382b4b6
--- /dev/null
+++ b/net-misc/openvpn/openvpn-1.3.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.3.2-r1.ebuild,v 1.1 2003/05/20 18:05:19 rphillips Exp $
+
+IUSE="ssl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/openvpn/${P}.tar.gz"
+HOMEPAGE="http://openvpn.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND=">=dev-libs/lzo-1.07
+ virtual/linux-sources
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+
+ local myconf
+
+ use ssl || myconf='--disable-ssl --disable-crypto'
+
+ ./autogen.sh || die
+ econf || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING CHANGES INSTALL PORTS README
+ insinto /etc/init.d ; doins ${FILESDIR}/openvpn
+
+}