summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rdesktop/rdesktop-1.3.1.ebuild')
-rw-r--r--net-misc/rdesktop/rdesktop-1.3.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/rdesktop/rdesktop-1.3.1.ebuild b/net-misc/rdesktop/rdesktop-1.3.1.ebuild
new file mode 100644
index 000000000000..9b3cc4409b8c
--- /dev/null
+++ b/net-misc/rdesktop/rdesktop-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/rdesktop-1.3.1.ebuild,v 1.1 2004/01/24 20:36:07 wolf31o2 Exp $
+
+DESCRIPTION="A Remote Desktop Protocol Client"
+HOMEPAGE="http://rdesktop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ssl debug"
+
+DEPEND="x11-base/xfree
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ local myconf
+ use ssl \
+ && myconf="--with-openssl=/usr/include/openssl" \
+ || myconf="--without-openssl"
+
+ sed -e "s:-O2:${CFLAGS}:g" Makefile > Makefile.tmp
+ mv Makefile.tmp Makefile
+ echo "CFLAGS += ${CXXFLAGS}" >> Makeconf
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sharedir=/usr/share/${PN} \
+ `use_with debug` \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dodoc COPYING doc/HACKING doc/TODO doc/keymapping.txt
+}