summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rsync/rsync-2.6.3_pre2.ebuild')
-rw-r--r--net-misc/rsync/rsync-2.6.3_pre2.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/net-misc/rsync/rsync-2.6.3_pre2.ebuild b/net-misc/rsync/rsync-2.6.3_pre2.ebuild
deleted file mode 100644
index 691bc8d5708c..000000000000
--- a/net-misc/rsync/rsync-2.6.3_pre2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.3_pre2.ebuild,v 1.1 2004/09/25 06:52:04 vapier Exp $
-
-inherit eutils flag-o-matic gcc
-
-DESCRIPTION="File transfer program to keep remote files into sync"
-HOMEPAGE="http://rsync.samba.org/"
-SRC_URI="http://rsync.samba.org/ftp/rsync/preview/${P/_/}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
-IUSE="build static acl ipv6"
-
-RDEPEND="virtual/libc
- !build? ( >=dev-libs/popt-1.5 )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- acl? ( sys-apps/acl )"
-
-S="${WORKDIR}/${P/_/}"
-
-src_unpack() {
- unpack "${P/_/}.tar.gz"
- cd ${S}
- use acl && epatch patches/acl.diff
-
- # change confdir to /etc/rsync rather than just /etc (the --sysconfdir
- # yes, updating the man page is very important.
- sed -i \
- -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' \
- rsyncd.conf.5 \
- || die "sed rsyncd.conf.5 failed"
-}
-
-src_compile() {
- [ "`gcc-version`" == "2.95" ] && append-ldflags -lpthread
- use static && append-ldflags -static
-
- econf \
- $(use_with build included-popt) \
- $(use_with acl acl-support) \
- $(use_enable ipv6) \
- --with-rsyncd-conf=/etc/rsync/rsyncd.conf \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- insinto /etc/conf.d && newins "${FILESDIR}/rsyncd.conf.d" rsyncd
- exeinto /etc/init.d && newexe "${FILESDIR}/rsyncd.init.d" rsyncd
- if ! use build ; then
- dodir /etc/rsync
- dodoc NEWS OLDNEWS README TODO tech_report.tex
- if [ ! -e /etc/rsync/rsyncd.conf ] ; then
- insinto /etc/rsync
- doins "${FILESDIR}/rsyncd.conf"
- fi
- else
- rm -rf "${D}/usr/share"
- fi
-}
-
-pkg_postinst() {
- ewarn "Please make sure you do NOT disable the rsync server running"
- ewarn "in a chroot. Please check /etc/rsync/rsyncd.conf and make sure"
- ewarn "it says: use chroot = yes"
-}