summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/ChangeLog26
-rw-r--r--net-misc/stunnel/files/digest-stunnel-4.021
-rw-r--r--net-misc/stunnel/files/stunnel-4.02-gentoo.diff12
-rw-r--r--net-misc/stunnel/files/stunnel.conf50
-rw-r--r--net-misc/stunnel/files/stunnel.rc620
-rw-r--r--net-misc/stunnel/stunnel-4.02.ebuild49
6 files changed, 138 insertions, 20 deletions
diff --git a/net-misc/stunnel/ChangeLog b/net-misc/stunnel/ChangeLog
index b6f9765695f7..becad3b43152 100644
--- a/net-misc/stunnel/ChangeLog
+++ b/net-misc/stunnel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/stunnel
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.2 2002/07/09 11:11:02 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.3 2002/10/26 23:42:32 aliz Exp $
+
+*stunnel-4.02 (26 Oct 2002)
+
+ 26 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump, found by fluxbox <fluxbox@cox.net> in #9512.
*stunnel-3.22-r1 (18 Mar 2002)
@@ -10,22 +15,3 @@
18 Mar 2002; Seemant Kulleen <seemant@gentoo.org> stunnel-3.22-r1.ebuild :
Unmasked it, and made the dep >= instead of >, and added ChangeLog file.
-
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
- This changelog is targetted to users. This means that the comments should be
- well explained and written in clean English.
-
- Every new version or revision of the package has to be marked by a '*'
- seperator line as above. Changements since the last revision have to be
- added to the top of the file, underneath the initial copyright and cvs header
- comments, in exactly the same format as this comment.
-
- This means that you start with header line that has the following format :
-
- date; your_name <your_email> changed_file1, changed_file2 :
-
- Below that line your explanation should follow. It has to be indented,
- paragraphed and wrapped at a linewidth of 80 characters.
-
- Any details about what exactly changed in the code should be added as a
- message when the changes are committed to cvs, not in this file.
diff --git a/net-misc/stunnel/files/digest-stunnel-4.02 b/net-misc/stunnel/files/digest-stunnel-4.02
new file mode 100644
index 000000000000..fea2627efd09
--- /dev/null
+++ b/net-misc/stunnel/files/digest-stunnel-4.02
@@ -0,0 +1 @@
+MD5 78ba0250d55120e4f42ee623cd06c04d stunnel-4.02.tar.gz 297962
diff --git a/net-misc/stunnel/files/stunnel-4.02-gentoo.diff b/net-misc/stunnel/files/stunnel-4.02-gentoo.diff
new file mode 100644
index 000000000000..b41de790e162
--- /dev/null
+++ b/net-misc/stunnel/files/stunnel-4.02-gentoo.diff
@@ -0,0 +1,12 @@
+--- tools/Makefile.in 2002-10-26 16:48:22.000000000 +0000
++++ tools/Makefile.in 2002-10-26 16:48:38.000000000 +0000
+@@ -83,7 +83,7 @@
+
+
+ confdir = $(sysconfdir)/stunnel
+-conf_DATA = stunnel.conf-sample stunnel.pem
++conf_DATA = stunnel.conf-sample
+
+ docdir = $(datadir)/doc/stunnel
+ examplesdir = $(docdir)/examples
+
diff --git a/net-misc/stunnel/files/stunnel.conf b/net-misc/stunnel/files/stunnel.conf
new file mode 100644
index 000000000000..4114349df8cc
--- /dev/null
+++ b/net-misc/stunnel/files/stunnel.conf
@@ -0,0 +1,50 @@
+# location of pid file
+pid = /var/run/stunnel.pid
+
+# user to run as
+setuid = nobody
+setgid = nogroup
+
+# Authentication stuff
+#verify = 2
+# don't forget about c_rehash CApath
+# it is located inside chroot jail:
+#CApath = /certs
+# or simply use CAfile instead:
+#CAfile = /usr/etc/stunnel/certs.pem
+
+# Some debugging stuff
+#debug = 7
+#output = stunnel.log
+
+# Use it for client mode
+#client = yes
+
+# sample service-level configuration
+
+#[pop3s]
+#accept = 995
+#connect = 110
+
+#[imaps]
+#accept = 993
+#connect = 143
+
+#[ssmtp]
+#accept = 465
+#connect = 25
+
+#[s1]
+#accept = 5000
+#connect = mail.osw.pl:110
+#delay = yes
+
+#[s2]
+#accept = 5001
+#connect = mail.osw.pl:25
+
+#[https]
+#accept = 443
+#connect = 80
+#TIMEOUTclose = 0
+
diff --git a/net-misc/stunnel/files/stunnel.rc6 b/net-misc/stunnel/files/stunnel.rc6
new file mode 100644
index 000000000000..7bcbe435d6a2
--- /dev/null
+++ b/net-misc/stunnel/files/stunnel.rc6
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/files/stunnel.rc6,v 1.1 2002/10/26 23:42:32 aliz Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting stunnel"
+ start-stop-daemon --start --quiet --exec /usr/sbin/stunnel
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping net-snmpd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/stunnel
+ eend $?
+}
diff --git a/net-misc/stunnel/stunnel-4.02.ebuild b/net-misc/stunnel/stunnel-4.02.ebuild
new file mode 100644
index 000000000000..f6195b973198
--- /dev/null
+++ b/net-misc/stunnel/stunnel-4.02.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.02.ebuild,v 1.1 2002/10/26 23:42:32 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TSL/SSL - Port Wrapper"
+SRC_URI="http://www.stunnel.org/download/stunnel/src/${P}.tar.gz"
+HOMEPAGE="http://stunnel.mirt.net"
+DEPEND="virtual/glibc >=dev-libs/openssl-0.9.6c"
+RDEPEND=">=dev-libs/openssl-0.9.6c"
+KEYWORDS="~x86 ~sparc ~sparc64"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ ./configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dosbin src/stunnel
+ dodoc AUTHORS BUGS COPYING COPYRIGHT.GPL CREDITS INSTALL NEWS PORTS README TODO
+ dodoc doc/en/transproxy.txt
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html tools/importCA.html
+ doman doc/stunnel.8
+
+ insinto /usr/share/doc/${PF}
+ doins tools/ca.pl tools/importCA.sh
+
+ insinto /etc/init.d
+ newins ${FILESDIR}/stunnel.rc6 stunnel
+
+ dolib src/.libs/libstunnel.la
+ dolib.so src/.libs/libstunnel.so
+
+ insinto /etc
+ doins ${FILESDIR}/stunnel.conf
+}
+
+pkg_postinst() {
+ einfo "Starting from version 4 stunnel now uses a configuration file for setting up stunnels."
+ einfo "Stunnel can now also be run as a daemon"
+}