summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/snownews/snownews-1.5.12-r1.ebuild')
-rw-r--r--net-news/snownews/snownews-1.5.12-r1.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/net-news/snownews/snownews-1.5.12-r1.ebuild b/net-news/snownews/snownews-1.5.12-r1.ebuild
index 4d31ee6460c4..97d2898df1fc 100644
--- a/net-news/snownews/snownews-1.5.12-r1.ebuild
+++ b/net-news/snownews/snownews-1.5.12-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/snownews-1.5.12-r1.ebuild,v 1.2 2010/03/17 13:23:29 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/snownews-1.5.12-r1.ebuild,v 1.3 2010/05/12 22:17:29 darkside Exp $
+EAPI=3
inherit eutils toolchain-funcs
DESCRIPTION="Snownews, a text-mode RSS/RDF newsreader"
@@ -10,7 +11,7 @@ SRC_URI="http://home.kcore.de/~kiza/software/snownews/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
IUSE="unicode"
DEPEND=">=dev-libs/libxml2-2.5.6
@@ -28,10 +29,7 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
use unicode && sed -i -e "s/-lncurses/-lncursesw/" \
configure
@@ -42,14 +40,17 @@ src_unpack() {
Makefile
}
-src_compile() {
- local conf="--prefix=/usr"
+src_configure() {
+ local conf="--prefix=${EPREFIX}/usr"
./configure ${conf} || die "configure failed"
+}
+
+src_compile() {
emake CC="$(tc-getCC)" EXTRA_CFLAGS="${CFLAGS}" EXTRA_LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {
- emake PREFIX="${D}/usr" install || die "make install failed"
+ emake PREFIX="${ED}/usr" install || die "make install failed"
dodoc AUTHOR Changelog CREDITS README README.de README.patching
}