summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/maestro/maestro-2004.ebuild')
-rw-r--r--sci-astronomy/maestro/maestro-2004.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-astronomy/maestro/maestro-2004.ebuild b/sci-astronomy/maestro/maestro-2004.ebuild
new file mode 100644
index 000000000000..ec7f7e74ae4f
--- /dev/null
+++ b/sci-astronomy/maestro/maestro-2004.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/maestro/maestro-2004.ebuild,v 1.1 2004/12/24 03:53:41 ribosome Exp $
+
+DESCRIPTION="Maestro is a public release software package that NASA scientists use to operate the Spirit and Opportunity Rovers."
+SRC_URI="http://freecache.org/http://mars9.telascience.org:81/softwaredownload/Maestro-Linux.tar.gz"
+HOMEPAGE="http://mars.telascience.org/"
+IUSE=""
+DEPEND=""
+RDEPEND=">=virtual/jre-1.4"
+LICENSE="maestro"
+SLOT="0"
+KEYWORDS="x86"
+
+S=${WORKDIR}/R2004_02-Public-Linux
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/JPL/SAP/WITS-db
+ einfo "Unpacking default data sets..."
+ tar xf mer.tar
+ rm mer.tar
+ cd ${S}
+}
+
+src_install () {
+ dodir /opt/${PN}
+ cp -r JPL/ ${D}/opt/${PN}
+ echo "#!/bin/sh" >> ${PN}
+ echo "cd /opt/${PN}/JPL/SAP/bin" >> ${PN}
+ echo "./SAP" >> ${PN}
+ into /opt
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Dataset updates can be found online at:"
+ einfo " http://mars.telascience.org/update"
+ einfo
+ einfo "To run maestro, simply type: maestro"
+ einfo
+}