summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cln/cln-1.2.1.ebuild')
-rw-r--r--sci-libs/cln/cln-1.2.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/cln/cln-1.2.1.ebuild b/sci-libs/cln/cln-1.2.1.ebuild
new file mode 100644
index 000000000000..204a31018cb5
--- /dev/null
+++ b/sci-libs/cln/cln-1.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.2.1.ebuild,v 1.1 2008/03/28 14:44:13 bicatali Exp $
+
+inherit flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="CLN, a class library (C++) for numbers"
+
+HOMEPAGE="http://www.ginac.de/CLN/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gnu/${P}.tar.bz2
+ ftp://ftp.santafe.edu/pub/gnu/${P}.tar.bz2
+ ftp://ftp.ilog.fr/pub/Users/haible/gnu/${P}.tar.bz2"
+DEPEND="dev-libs/gmp"
+
+src_compile () {
+ # -Os causes segmentation faults (see bug #174576)
+ # checked for 1.2.1, gcc-4.2.3
+ replace-flags -Os -O2
+
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --datadir=/usr/share/doc/${PF} || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}