summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libghemical/ChangeLog10
-rw-r--r--sci-libs/libghemical/files/libghemical-gcc43.patch21
-rw-r--r--sci-libs/libghemical/libghemical-2.00.ebuild6
-rw-r--r--sci-libs/libghemical/libghemical-2.10.ebuild7
4 files changed, 36 insertions, 8 deletions
diff --git a/sci-libs/libghemical/ChangeLog b/sci-libs/libghemical/ChangeLog
index 31e8a9cfc901..6e1a84fd96e5 100644
--- a/sci-libs/libghemical/ChangeLog
+++ b/sci-libs/libghemical/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libghemical
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/ChangeLog,v 1.13 2006/12/28 22:30:59 je_fro Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/ChangeLog,v 1.14 2008/06/09 09:15:45 je_fro Exp $
+
+ 09 Jun 2008; Jeff Gardner <je_fro@gentoo.org>
+ +files/libghemical-gcc43.patch, libghemical-2.00.ebuild,
+ libghemical-2.10.ebuild:
+ Patch to allow compilation with gcc-4.3. Many thanks to Marek Miller on
+ bug #225401.
*libghemical-2.10 (28 Dec 2006)
diff --git a/sci-libs/libghemical/files/libghemical-gcc43.patch b/sci-libs/libghemical/files/libghemical-gcc43.patch
new file mode 100644
index 000000000000..53db5fba4d90
--- /dev/null
+++ b/sci-libs/libghemical/files/libghemical-gcc43.patch
@@ -0,0 +1,21 @@
+--- src/atom.h.orig 2008-06-09 03:59:34.262567972 -0500
++++ src/atom.h 2008-06-09 04:00:07.136698792 -0500
+@@ -10,6 +10,8 @@
+ #ifndef ATOM_H
+ #define ATOM_H
+
++#include <cstdlib>
++#include <cstring>
+ #include "libghemicaldefine.h"
+ #include "libghemicalconfig2.h"
+
+--- src/notice.h.orig 2008-06-09 04:00:24.472509840 -0500
++++ src/notice.h 2008-06-09 04:00:44.608265748 -0500
+@@ -10,6 +10,7 @@
+ #ifndef NOTICE_H
+ #define NOTICE_H
+
++#include <cstring>
+ #include "libghemicaldefine.h"
+ #include "libghemicalconfig2.h"
+
diff --git a/sci-libs/libghemical/libghemical-2.00.ebuild b/sci-libs/libghemical/libghemical-2.00.ebuild
index cdec23e108ba..3ef8159648c9 100644
--- a/sci-libs/libghemical/libghemical-2.00.ebuild
+++ b/sci-libs/libghemical/libghemical-2.00.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-2.00.ebuild,v 1.4 2006/11/24 21:49:01 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-2.00.ebuild,v 1.5 2008/06/09 09:15:45 je_fro Exp $
inherit autotools eutils
@@ -20,7 +20,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${PV}-really-find-blas-and-lapack.patch
+ epatch "${FILESDIR}"/${PV}-really-find-blas-and-lapack.patch
cd "${S}"
eautoreconf
}
diff --git a/sci-libs/libghemical/libghemical-2.10.ebuild b/sci-libs/libghemical/libghemical-2.10.ebuild
index 5291c9ce940f..575e8d804d68 100644
--- a/sci-libs/libghemical/libghemical-2.10.ebuild
+++ b/sci-libs/libghemical/libghemical-2.10.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-2.10.ebuild,v 1.2 2007/07/13 06:57:50 mr_bones_ Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-2.10.ebuild,v 1.3 2008/06/09 09:15:45 je_fro Exp $
+inherit autotools
DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
HOMEPAGE="http://bioinformatics.org/ghemical/"
SRC_URI="http://www.bioinformatics.org/ghemical/download/${P}.tar.gz"
@@ -21,6 +21,7 @@ RDEPEND="mopac7? ( sci-chemistry/mopac7 )
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${PN}-gcc43.patch
eautoreconf
}