summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/relational')
-rw-r--r--sci-mathematics/relational/ChangeLog8
-rw-r--r--sci-mathematics/relational/relational-0.11.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/sci-mathematics/relational/ChangeLog b/sci-mathematics/relational/ChangeLog
index 3342d24d3c29..a763cc756669 100644
--- a/sci-mathematics/relational/ChangeLog
+++ b/sci-mathematics/relational/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/relational
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/ChangeLog,v 1.4 2010/04/30 10:57:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/ChangeLog,v 1.5 2010/07/08 14:55:42 hwoarang Exp $
+
+*relational-0.11 (08 Jul 2010)
+
+ 08 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+ +relational-0.11.ebuild:
+ Version bump
30 Apr 2010; Markos Chandras <hwoarang@gentoo.org> relational-0.10.ebuild:
Minor fixes to match the latest update on python eclass. Fixes bug #316235
diff --git a/sci-mathematics/relational/relational-0.11.ebuild b/sci-mathematics/relational/relational-0.11.ebuild
new file mode 100644
index 000000000000..13dab3ed4ea3
--- /dev/null
+++ b/sci-mathematics/relational/relational-0.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/relational-0.11.ebuild,v 1.1 2010/07/08 14:55:42 hwoarang Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python distutils eutils
+
+DESCRIPTION="Qt4 relational algebra application"
+HOMEPAGE="http://galileo.dmi.unict.it/wiki/relational/"
+# upstream url is not static
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-python/PyQt4[webkit,X]
+ media-fonts/dejavu"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ insinto "$(python_get_sitedir)/"
+ doins -r "${PN}_gui" || die "doins failed"
+ doins -r "${PN}" || die "doins failed"
+ newbin ${PN}_gui.py ${PN} || die "dobin failed"
+ domenu ${PN}.desktop || die "domenu failed"
+ dodoc CHANGELOG CREDITS README || die "dodoc failed"
+ doman ${PN}.1 || die "doman failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN} ${PN}_gui
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN} ${PN}_gui
+}