summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/acl/acl-2.2.45.ebuild')
-rw-r--r--sys-apps/acl/acl-2.2.45.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/sys-apps/acl/acl-2.2.45.ebuild b/sys-apps/acl/acl-2.2.45.ebuild
index f0165e4f2693..8e47a1b4bfe4 100644
--- a/sys-apps/acl/acl-2.2.45.ebuild
+++ b/sys-apps/acl/acl-2.2.45.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.45.ebuild,v 1.12 2007/12/11 10:18:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.45.ebuild,v 1.13 2008/02/23 03:05:17 vapier Exp $
inherit eutils autotools toolchain-funcs
@@ -9,7 +9,7 @@ DESCRIPTION="Access control list utilities, libraries and headers"
HOMEPAGE="http://oss.sgi.com/projects/xfs/"
SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz
- nfs? ( http://www.citi.umich.edu/projects/nfsv4/linux/acl-patches/2.2.42-1/acl-2.2.42-CITI_NFS4_ALL-1.dif )"
+ nfs? ( http://www.citi.umich.edu/projects/nfsv4/linux/acl-patches/2.2.42-2/acl-2.2.42-CITI_NFS4_ALL-2.dif )"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -25,19 +25,23 @@ src_unpack() {
unpack ${MY_P}.tar.gz
cd "${S}"
if use nfs ; then
- cp "${DISTDIR}"/acl-2.2.42-CITI_NFS4_ALL-1.dif . || die
- epatch \
- "${FILESDIR}"/acl-2.2.42-nfs-glue.patch \
- acl-2.2.42-CITI_NFS4_ALL-1.dif
+ cp "${DISTDIR}"/acl-2.2.42-CITI_NFS4_ALL-2.dif . || die
+ sed -i '/^diff --git a.debian.changelog b.debian.changelog/,/^diff --git/d' acl-2.2.42-CITI_NFS4_ALL-2.dif || die
+ epatch acl-2.2.42-CITI_NFS4_ALL-2.dif
fi
epatch "${FILESDIR}"/${PN}-2.2.45-libtool.patch #158068
+ epatch "${FILESDIR}"/${PN}-2.2.45-linguas.patch #205948
epatch "${FILESDIR}"/${PN}-2.2.32-only-symlink-when-needed.patch
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
-e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
include/builddefs.in \
|| die "failed to update builddefs"
+ # libtool will clobber install-sh which is really a custom file
+ mv install-sh acl.install-sh || die
AT_M4DIR="m4" eautoreconf
+ mv acl.install-sh install-sh || die
+ strip-linguas po
}
src_compile() {