summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/texinfo/texinfo-4.13.ebuild')
-rw-r--r--sys-apps/texinfo/texinfo-4.13.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/texinfo/texinfo-4.13.ebuild b/sys-apps/texinfo/texinfo-4.13.ebuild
new file mode 100644
index 000000000000..b1f193dde709
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-4.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.13.ebuild,v 1.1 2008/10/22 05:34:03 robbat2 Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="http://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls static"
+
+RDEPEND="!=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf $(use_enable nls) || die
+ emake || die "emake"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog INTRODUCTION NEWS README TODO
+ newdoc info/README README.info
+ newdoc makeinfo/README README.makeinfo
+
+ rm -f "${D}"/usr/lib/charset.alias #195148
+}