summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog6
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.1.ebuild14
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.2.ebuild15
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.3.ebuild15
4 files changed, 19 insertions, 31 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 5dc31ad0bc15..26076f846e58 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.75 2010/12/05 16:09:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.76 2010/12/16 15:59:56 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> openmpi-1.4.1.ebuild,
+ openmpi-1.4.2.ebuild, openmpi-1.4.3.ebuild:
+ Removal of fortran.eclass, #348851
05 Dec 2010; Raúl Porcel <armin76@gentoo.org> openmpi-1.4.2.ebuild:
ia64 stable wrt #337129
diff --git a/sys-cluster/openmpi/openmpi-1.4.1.ebuild b/sys-cluster/openmpi/openmpi-1.4.1.ebuild
index b44ceace5187..4b2457e4ddf2 100644
--- a/sys-cluster/openmpi/openmpi-1.4.1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.1.ebuild,v 1.9 2010/06/25 19:02:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.1.ebuild,v 1.10 2010/12/16 15:59:56 jlec Exp $
EAPI=2
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
+inherit eutils multilib flag-o-matic toolchain-funcs
MY_P=${P/-mpi}
S=${WORKDIR}/${MY_P}
@@ -43,11 +43,6 @@ pkg_setup() {
elog "Don't forget the EXTRA_ECONF environment variable can let you"
elog "specify configure options if you find them necessary."
elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
}
src_prepare() {
@@ -60,7 +55,6 @@ src_prepare() {
# https://svn.open-mpi.org/trac/ompi/ticket/2201
epatch "${FILESDIR}"/${P}-r22513.patch
-
}
src_configure() {
@@ -78,9 +72,9 @@ src_configure() {
fi
if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
+ if [[ "$(tc-getFC)" = "g77" ]]; then
myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = if* ]]; then
+ elif [[ "$(tc-getFC)" = if* ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
myconf="${myconf} --with-mpi-f90-size=medium"
fi
diff --git a/sys-cluster/openmpi/openmpi-1.4.2.ebuild b/sys-cluster/openmpi/openmpi-1.4.2.ebuild
index ce98b84824d3..16d071017a08 100644
--- a/sys-cluster/openmpi/openmpi-1.4.2.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.2.ebuild,v 1.7 2010/12/05 16:09:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.2.ebuild,v 1.8 2010/12/16 15:59:56 jlec Exp $
EAPI=3
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
+inherit eutils multilib flag-o-matic toolchain-funcs
MY_P=${P/-mpi}
S=${WORKDIR}/${MY_P}
@@ -42,11 +42,6 @@ pkg_setup() {
elog "Don't forget the EXTRA_ECONF environment variable can let you"
elog "specify configure options if you find them necessary."
echo
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
}
src_prepare() {
@@ -60,7 +55,7 @@ src_prepare() {
src_configure() {
local myconf="
- --sysconfdir=${EPREFIX}/etc/${PN}
+ --sysconfdir="${EPREFIX}"/etc/${PN}
--without-xgrid
--enable-pretty-print-stacktrace
--enable-orterun-prefix-by-default
@@ -73,9 +68,9 @@ src_configure() {
fi
if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
+ if [[ "$(tc-getFC)" = "g77" ]]; then
myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = if* ]]; then
+ elif [[ "$(tc-getFC)" = if* ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
myconf="${myconf} --with-mpi-f90-size=medium"
fi
diff --git a/sys-cluster/openmpi/openmpi-1.4.3.ebuild b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
index 0adea85fdc9d..7a194f613085 100644
--- a/sys-cluster/openmpi/openmpi-1.4.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.2 2010/10/24 17:28:17 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.3 2010/12/16 15:59:56 jlec Exp $
EAPI=3
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
+inherit eutils multilib flag-o-matic toolchain-funcs
MY_P=${P/-mpi}
S=${WORKDIR}/${MY_P}
@@ -42,11 +42,6 @@ pkg_setup() {
elog "Don't forget the EXTRA_ECONF environment variable can let you"
elog "specify configure options if you find them necessary."
echo
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
}
src_prepare() {
@@ -60,7 +55,7 @@ src_prepare() {
src_configure() {
local myconf="
- --sysconfdir=${EPREFIX}/etc/${PN}
+ --sysconfdir="${EPREFIX}"/etc/${PN}
--enable-pretty-print-stacktrace
--enable-orterun-prefix-by-default
--without-slurm"
@@ -72,9 +67,9 @@ src_configure() {
fi
if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
+ if [[ "$(tc-getFC)" = "g77" ]]; then
myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = if* ]]; then
+ elif [[ "$(tc-getFC)" = if* ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
myconf="${myconf} --with-mpi-f90-size=medium"
fi