summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gettext/gettext-0.14.1.ebuild')
-rw-r--r--sys-devel/gettext/gettext-0.14.1.ebuild60
1 files changed, 27 insertions, 33 deletions
diff --git a/sys-devel/gettext/gettext-0.14.1.ebuild b/sys-devel/gettext/gettext-0.14.1.ebuild
index 9eba89d6e532..941ab7c93aa4 100644
--- a/sys-devel/gettext/gettext-0.14.1.ebuild
+++ b/sys-devel/gettext/gettext-0.14.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.14.1.ebuild,v 1.11 2004/10/28 15:57:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.14.1.ebuild,v 1.12 2004/10/31 08:53:00 vapier Exp $
-inherit eutils gnuconfig toolchain-funcs mono
+inherit eutils gnuconfig toolchain-funcs mono libtool
DESCRIPTION="GNU locale utilities"
HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
@@ -19,38 +19,29 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
+
+ # remove C++ requirements while bootstrapping
use bootstrap && epatch ${WORKDIR}/${P}-bootstrap.patch
- if use sparc; then
- epatch ${FILESDIR}/${P}-without_java.patch
- epatch ${FILESDIR}/${P}-no-java-tests.patch
- fi
+
+ # java sucks
+ epatch ${FILESDIR}/${P}-without_java.patch
+ epatch ${FILESDIR}/${P}-no-java-tests.patch
+
+ elibtoolize --reverse-deps
gnuconfig_update
}
src_compile() {
- # Compaq Java segfaults trying to build gettext stuff, and there's
- # no good way to tell gettext to refrain from building the java
- # stuff, so... remove compaq-jdk/jre from the PATH
- if use alpha && [[ $JAVAC == *compaq* ]]; then
- PATH=$(echo ":${PATH}" | sed 's|:/opt/compaq-j[^:]*||g; s/^://')
- unset JAVA_HOME CLASSPATH JDK_HOME JAVAC
- fi
-
- # When updating in sparc with java the jvm segfaults
- use sparc && myconf="${myconf} --without-java"
- use ppc-macos && myconf="${myconf} --enable-nls"
-
# Build with --without-included-gettext (will use that of glibc), as we
# need preloadable_libintl.so for new help2man, bug #40162.
# Also note that it only gets build with USE=nls ...
# Lastly, we need to build without --disable-shared ...
CXX=$(tc-getCC) \
- econf \
+ econf \
+ --without-java \
--without-included-gettext \
$(use_enable nls) \
- ${myconf} \
|| die
-
emake || die
}
@@ -65,15 +56,20 @@ src_install() {
exeinto /usr/bin
doexe gettext-tools/misc/gettextize || die "doexe"
- # Glibc includes gettext; this isn't needed anymore
-# rm -rf ${D}/usr/include
-# rm -rf ${D}/usr/lib/lib*.{a,so}
-
- # Again, installed by glibc
+ # remove stuff that glibc handles
+ rm -f ${D}/usr/include/libintl.h
+ rm -f ${D}/usr/$(get_libdir)/libintl.*
rm -rf ${D}/usr/share/locale/locale.alias
-
# /usr/lib/charset.alias is provided by Mac OS X
- ( use macos || use ppc-macos ) && rm -f ${D}/usr/lib/charset.alias
+ use ppc-macos && rm -f ${D}/usr/lib/charset.alias
+
+ # older gettext's sometimes installed libintl ...
+ # need to keep the linked version or the system
+ # could die (things like sed link against it :/)
+ if [ -e "${ROOT}"/usr/$(get_libdir)/libintl.so.2 ] ; then
+ cp -a ${ROOT}/usr/$(get_libdir)/libintl.so.2* ${D}/usr/$(get_libdir)/
+ touch ${D}/usr/$(get_libdir)/libintl.so.2*
+ fi
if [ -d ${D}/usr/doc/gettext ]
then
@@ -82,10 +78,7 @@ src_install() {
fi
# Remove emacs site-lisp stuff if 'emacs' is not in USE
- if ! use emacs
- then
- rm -rf ${D}/usr/share/emacs
- fi
+ use emacs || rm -rf ${D}/usr/share/emacs
dodoc AUTHORS BUGS ChangeLog DISCLAIM NEWS README* THANKS TODO
}
@@ -93,5 +86,6 @@ src_install() {
pkg_postinst() {
ewarn "Any package that linked against the previous version"
ewarn "of gettext will have to be rebuilt."
- ewarn "Please 'emerge gentoolkit' and run 'revdep-rebuild'"
+ ewarn "Please 'emerge gentoolkit' and run:"
+ ewarn "revdep-rebuild --soname libintl.so.2"
}