summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/stubs/gcc-3.3-htb-stub.patch59
-rw-r--r--sys-devel/gcc/files/stubs/gcc-3.3-ssp-stub.patch45
-rw-r--r--sys-devel/gcc/files/stubs/gcc-3.4-htb-stub.patch32
-rw-r--r--sys-devel/gcc/files/stubs/gcc-3.4-ssp-stub.patch44
-rw-r--r--sys-devel/gcc/files/stubs/gcc-4.0-htb-stub.patch32
-rw-r--r--sys-devel/gcc/files/stubs/gcc-4.0-ssp-stub.patch44
7 files changed, 7 insertions, 257 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index aba94ad3b1fa..065f3ab74db9 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.836 2011/12/03 20:28:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.837 2011/12/03 20:48:13 vapier Exp $
+
+ 03 Dec 2011; Mike Frysinger <vapier@gentoo.org>
+ -files/stubs/gcc-3.3-htb-stub.patch, -files/stubs/gcc-3.3-ssp-stub.patch,
+ -files/stubs/gcc-3.4-htb-stub.patch, -files/stubs/gcc-3.4-ssp-stub.patch,
+ -files/stubs/gcc-4.0-htb-stub.patch, -files/stubs/gcc-4.0-ssp-stub.patch:
+ Drop now unused stub patches.
03 Dec 2011; Mike Frysinger <vapier@gentoo.org> gcc-4.6.0.ebuild,
gcc-4.6.1-r1.ebuild, gcc-4.6.2.ebuild:
diff --git a/sys-devel/gcc/files/stubs/gcc-3.3-htb-stub.patch b/sys-devel/gcc/files/stubs/gcc-3.3-htb-stub.patch
deleted file mode 100644
index f6d81040c58c..000000000000
--- a/sys-devel/gcc/files/stubs/gcc-3.3-htb-stub.patch
+++ /dev/null
@@ -1,59 +0,0 @@
---- gcc-3.3.6/gcc/c-opts.c
-+++ gcc-3.3.6/gcc/c-opts.c
-@@ -193,6 +193,8 @@ static void sanitize_cpp_opts PARAMS ((v
- OPT("fall-virtual", CL_CXX, OPT_fall_virtual) \
- OPT("falt-external-templates",CL_CXX, OPT_falt_external_templates) \
- OPT("fasm", CL_ALL, OPT_fasm) \
-+ OPT("fbc-strings-only", CL_ALL, OPT_fbc_strings_only) \
-+ OPT("fbounds-checking", CL_ALL, OPT_fbounds_checking) \
- OPT("fbuiltin", CL_ALL, OPT_fbuiltin) \
- OPT("fbuiltin-", CL_ALL | CL_JOINED, OPT_fbuiltin_) \
- OPT("fcheck-new", CL_CXX, OPT_fcheck_new) \
-@@ -1037,6 +1039,11 @@ c_common_decode_option (argc, argv)
- flag_no_asm = !on;
- break;
-
-+ case OPT_fbounds_checking:
-+ case OPT_fbc_strings_only:
-+ warning ("htb stub: bounds checking is not supported");
-+ break;
-+
- case OPT_fbuiltin:
- flag_no_builtin = !on;
- break;
---- gcc-3.3.6/gcc/cp/lang-options.h
-+++ gcc-3.3.6/gcc/cp/lang-options.h
-@@ -32,6 +32,8 @@ DEFINE_LANG_NAME ("C++")
- { "-fno-alt-external-templates", "" },
- { "-fansi-overloading", "" },
- { "-fno-ansi-overloading", "" },
-+ { "-fbounds-checking", "" },
-+ { "-fno-bounds-checking", "" },
- { "-fcheck-new",
- N_("Check the return value of new") },
- { "-fno-check-new", "" },
-@@ -117,6 +119,9 @@ DEFINE_LANG_NAME ("C++")
- { "-fxref",
- N_("Emit cross referencing information") },
- { "-fno-xref", "" },
-+ { "-fbounds-checking",
-+ N_("Generate array and pointer bounds checking code") },
-+ { "-fno-bounds-checking", "" },
-
- { "-Wreturn-type",
- N_("Warn about inconsistent return types") },
---- gcc-3.3.6/gcc/toplev.c
-+++ gcc-3.3.6/gcc/toplev.c
-@@ -1249,6 +1267,12 @@ documented_lang_options[] =
- { "-fshort-wchar",
- N_("Override the underlying type for wchar_t to `unsigned short'") },
- { "-fno-short-wchar", "" },
-+ { "-fbounds-checking",
-+ N_("Generate array and pointer bounds checking code") },
-+ { "-fno-bounds-checking", "" },
-+ { "-fbc-strings-only",
-+ N_("Restrict bounds checking to strings only") },
-+ { "-fno-bc-strings-only", "" },
-
- { "-Wall",
- N_("Enable most warning messages") },
diff --git a/sys-devel/gcc/files/stubs/gcc-3.3-ssp-stub.patch b/sys-devel/gcc/files/stubs/gcc-3.3-ssp-stub.patch
deleted file mode 100644
index ed996e7df428..000000000000
--- a/sys-devel/gcc/files/stubs/gcc-3.3-ssp-stub.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- gcc-3.3.6/gcc/toplev.c
-+++ gcc-3.3.6/gcc/toplev.c
-@@ -904,6 +904,10 @@ int align_functions_log;
- minimum function alignment. Zero means no alignment is forced. */
- int force_align_functions_log;
-
-+int flag_propolice_protection = 0;
-+int flag_stack_protection = 0;
-+int warn_stack_protector = 0;
-+
- /* Table of supported debugging formats. */
- static const struct
- {
-@@ -1188,6 +1197,10 @@ static const lang_independent_options f_
- N_("Trap for signed overflow in addition / subtraction / multiplication") },
- { "new-ra", &flag_new_regalloc, 1,
- N_("Use graph coloring register allocation.") },
-+ {"stack-protector", &flag_propolice_protection, 1,
-+ N_("Enables stack protection") },
-+ {"stack-protector-all", &flag_stack_protection, 1,
-+ N_("Enables stack protection of every function") } ,
- };
-
- /* Table of language-specific options. */
-@@ -1547,7 +1560,9 @@ static const lang_independent_options W_
- {"missing-noreturn", &warn_missing_noreturn, 1,
- N_("Warn about functions which might be candidates for attribute noreturn") },
- {"strict-aliasing", &warn_strict_aliasing, 1,
-- N_ ("Warn about code which might break the strict aliasing rules") }
-+ N_ ("Warn about code which might break the strict aliasing rules") },
-+ {"stack-protector", &warn_stack_protector, 1,
-+ N_("Warn when disabling stack protector for some reason")}
- };
-
- void
-@@ -5230,6 +5247,9 @@ process_options ()
- /* The presence of IEEE signaling NaNs, implies all math can trap. */
- if (flag_signaling_nans)
- flag_trapping_math = 1;
-+
-+ if (flag_stack_protection || flag_propolice_protection)
-+ warning ("ssp stub: stack protector is not supported");
- }
-
- /* Initialize the compiler back end. */
diff --git a/sys-devel/gcc/files/stubs/gcc-3.4-htb-stub.patch b/sys-devel/gcc/files/stubs/gcc-3.4-htb-stub.patch
deleted file mode 100644
index 2be61a24013f..000000000000
--- a/sys-devel/gcc/files/stubs/gcc-3.4-htb-stub.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- gcc-3.4.4/gcc/c.opt
-+++ gcc-3.4.4/gcc/c.opt
-@@ -426,6 +426,14 @@ fasm
- C ObjC C++ ObjC++
- Recognize the \"asm\" keyword
-
-+fbounds-checking
-+C
-+Generate code to check bounds before indexing arrays
-+
-+fbc-strings-only
-+C
-+Restrict bounds checking to strings only
-+
- fbuiltin
- C ObjC C++ ObjC++
- Recognize built-in functions
---- gcc-3.4.4/gcc/c-opts.c
-+++ gcc-3.4.4/gcc/c-opts.c
-@@ -708,6 +708,12 @@ c_common_handle_option (size_t scode, co
- flag_no_asm = !value;
- break;
-
-+ case OPT_fbounds_checking:
-+ case OPT_fbc_strings_only:
-+ if (value)
-+ warning ("htb stub: bounds checking is not supported");
-+ break;
-+
- case OPT_fbuiltin:
- flag_no_builtin = !value;
- break;
diff --git a/sys-devel/gcc/files/stubs/gcc-3.4-ssp-stub.patch b/sys-devel/gcc/files/stubs/gcc-3.4-ssp-stub.patch
deleted file mode 100644
index 3f620f30caad..000000000000
--- a/sys-devel/gcc/files/stubs/gcc-3.4-ssp-stub.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- gcc-3.4.3/gcc/common.opt
-+++ gcc-3.4.3/gcc/common.opt
-@@ -152,6 +152,10 @@ Wunused-variable
- Common
- Warn when a variable is unused
-
-+Wstack-protector
-+Common
-+Warn when not issuing stack smashing protection for some reason
-+
- aux-info
- Common Separate
- -aux-info <file> Emit declaration information into <file>
-@@ -743,6 +747,14 @@ fzero-initialized-in-bss
- Common
- Put zero initialized data in the bss section
-
-+fstack-protector
-+Common
-+Enables stack protection
-+
-+fstack-protector-all
-+Common
-+Enables stack protection of every function
-+
- g
- Common JoinedOrMissing
- Generate debug information in default format
---- gcc-3.4.3/gcc/opts.c
-+++ gcc-3.4.3/gcc/opts.c
-@@ -804,6 +807,13 @@ common_handle_option (size_t scode, cons
- warn_unused_variable = value;
- break;
-
-+ case OPT_fstack_protector:
-+ case OPT_fstack_protector_all:
-+ case OPT_Wstack_protector:
-+ if (value)
-+ warning ("ssp stub: stack protector is not supported");
-+ break;
-+
- case OPT_aux_info:
- case OPT_aux_info_:
- aux_info_file_name = arg;
diff --git a/sys-devel/gcc/files/stubs/gcc-4.0-htb-stub.patch b/sys-devel/gcc/files/stubs/gcc-4.0-htb-stub.patch
deleted file mode 100644
index 4a515c56e23d..000000000000
--- a/sys-devel/gcc/files/stubs/gcc-4.0-htb-stub.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- gcc-4.0.0/gcc/c.opt
-+++ gcc-4.0.0/gcc/c.opt
-@@ -457,6 +457,14 @@ fasm
- C ObjC C++ ObjC++
- Recognize the \"asm\" keyword
-
-+fbounds-checking
-+C
-+Generate code to check bounds before indexing arrays
-+
-+fbc-strings-only
-+C
-+Restrict bounds checking to strings only
-+
- fbuiltin
- C ObjC C++ ObjC++
- Recognize built-in functions
---- gcc-4.0.0/gcc/c-opts.c
-+++ gcc-4.0.0/gcc/c-opts.c
-@@ -548,6 +549,12 @@ c_common_handle_option (size_t scode, co
- flag_no_asm = !value;
- break;
-
-+ case OPT_fbc_strings_only:
-+ case OPT_fbounds_checking:
-+ if (value)
-+ warning ("htb stub: bounds checking is not supported");
-+ break;
-+
- case OPT_fbuiltin:
- flag_no_builtin = !value;
- break;
diff --git a/sys-devel/gcc/files/stubs/gcc-4.0-ssp-stub.patch b/sys-devel/gcc/files/stubs/gcc-4.0-ssp-stub.patch
deleted file mode 100644
index 3f620f30caad..000000000000
--- a/sys-devel/gcc/files/stubs/gcc-4.0-ssp-stub.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- gcc-3.4.3/gcc/common.opt
-+++ gcc-3.4.3/gcc/common.opt
-@@ -152,6 +152,10 @@ Wunused-variable
- Common
- Warn when a variable is unused
-
-+Wstack-protector
-+Common
-+Warn when not issuing stack smashing protection for some reason
-+
- aux-info
- Common Separate
- -aux-info <file> Emit declaration information into <file>
-@@ -743,6 +747,14 @@ fzero-initialized-in-bss
- Common
- Put zero initialized data in the bss section
-
-+fstack-protector
-+Common
-+Enables stack protection
-+
-+fstack-protector-all
-+Common
-+Enables stack protection of every function
-+
- g
- Common JoinedOrMissing
- Generate debug information in default format
---- gcc-3.4.3/gcc/opts.c
-+++ gcc-3.4.3/gcc/opts.c
-@@ -804,6 +807,13 @@ common_handle_option (size_t scode, cons
- warn_unused_variable = value;
- break;
-
-+ case OPT_fstack_protector:
-+ case OPT_fstack_protector_all:
-+ case OPT_Wstack_protector:
-+ if (value)
-+ warning ("ssp stub: stack protector is not supported");
-+ break;
-+
- case OPT_aux_info:
- case OPT_aux_info_:
- aux_info_file_name = arg;