summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/traydevice/traydevice-1.6.2.ebuild')
-rw-r--r--sys-fs/traydevice/traydevice-1.6.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/traydevice/traydevice-1.6.2.ebuild b/sys-fs/traydevice/traydevice-1.6.2.ebuild
new file mode 100644
index 000000000000..6b6381ce14ca
--- /dev/null
+++ b/sys-fs/traydevice/traydevice-1.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/traydevice-1.6.2.ebuild,v 1.1 2013/05/11 18:37:21 hwoarang Exp $
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="A little desktop application displaying systray icon for UDisks"
+HOMEPAGE="http://savannah.nongnu.org/projects/traydevice/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ dev-python/lxml
+ dev-python/pyxdg
+ sys-fs/udisks:0"
+DEPEND="app-text/docbook2X"
+
+src_compile() { :; }
+
+src_install() {
+ distutils_src_install \
+ --prefix=/usr \
+ --install-data=/usr/share/${PN} \
+ --install-man=/usr/share/man \
+ --docbook2man=$(type -p docbook2man.pl)
+
+ rm -f "${D}"/usr/share/${PN}/*.txt
+}