summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/gdbm/gdbm-1.10-r1.ebuild')
-rw-r--r--sys-libs/gdbm/gdbm-1.10-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-libs/gdbm/gdbm-1.10-r1.ebuild b/sys-libs/gdbm/gdbm-1.10-r1.ebuild
index 6d6281b24213..7b0c00496961 100644
--- a/sys-libs/gdbm/gdbm-1.10-r1.ebuild
+++ b/sys-libs/gdbm/gdbm-1.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.10-r1.ebuild,v 1.1 2013/11/25 13:43:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.10-r1.ebuild,v 1.2 2013/11/28 19:58:40 vapier Exp $
EAPI="4"
@@ -15,7 +15,7 @@ SRC_URI="mirror://gnu/gdbm/${P}.tar.gz
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+berkdb exporter static-libs"
+IUSE="+berkdb exporter nls static-libs"
RDEPEND="
abi_x86_32? (
@@ -47,14 +47,12 @@ multilib_src_configure() {
--with-gdbm183-includedir="${EX_S}" \
$(use_enable berkdb libgdbm-compat) \
$(multilib_build_binaries && use_enable exporter gdbm-export) \
+ $(use_enable nls) \
$(use_enable static-libs static)
}
multilib_src_compile() {
- if use exporter ; then
- emake -C "${EX_S}" libgdbm.la
- fi
-
+ use exporter && emake -C "${EX_S}" libgdbm.la
emake
}