summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/ecore/ecore-1.0.0.20040403_pre6.ebuild')
-rw-r--r--x11-libs/ecore/ecore-1.0.0.20040403_pre6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-libs/ecore/ecore-1.0.0.20040403_pre6.ebuild b/x11-libs/ecore/ecore-1.0.0.20040403_pre6.ebuild
new file mode 100644
index 000000000000..74f11ed72dd0
--- /dev/null
+++ b/x11-libs/ecore/ecore-1.0.0.20040403_pre6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ecore/ecore-1.0.0.20040403_pre6.ebuild,v 1.1 2004/04/04 21:49:59 vapier Exp $
+
+inherit enlightenment
+
+DESCRIPTION="core event abstraction layer and X abstraction layer (nice convenience library)"
+HOMEPAGE="http://www.enlightenment.org/pages/ecore.html"
+
+IUSE="${IUSE} opengl fbcon X"
+
+DEPEND=">=x11-libs/evas-1.0.0.20040117_pre12
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+src_compile() {
+ export MY_ECONF="
+ `use_enable X ecore-x` \
+ --enable-ecore-job \
+ `use_enable fbcon ecore-fb` \
+ --enable-ecore-evas \
+ `use_enable opengl ecore-evas-gl` \
+ `use_enable fbcon ecore-evas-fb` \
+ --enable-ecore-con \
+ --enable-ecore-ipc \
+ --enable-ecore-txt \
+ --enable-ecore-config
+ "
+ enlightenment_src_compile
+}