summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/qt-x11/qt-x11-2.3.0.ebuild')
-rw-r--r--x11-libs/qt-x11/qt-x11-2.3.0.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/x11-libs/qt-x11/qt-x11-2.3.0.ebuild b/x11-libs/qt-x11/qt-x11-2.3.0.ebuild
index 02dfd29cb063..d35fa446f5c5 100644
--- a/x11-libs/qt-x11/qt-x11-2.3.0.ebuild
+++ b/x11-libs/qt-x11/qt-x11-2.3.0.ebuild
@@ -54,20 +54,16 @@ src_compile() {
myconf="${myconf} -release"
fi
+ try SYSCONF_CFLAGS=\"$CFLAGS\" SYSCONF_CXXFLAGS=\"$CXXFLAGS\" \
./configure -sm -thread -system-zlib -system-jpeg ${myconf} \
- -system-libmng -system-libpng -gif -platform linux-g++ -ldl -lpthread
-
- cd ${S}/src
- cp Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/tools
- cp Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/src/moc
- cp Makefile Makefile.orig
- sed -e "s/-pipe -O2/${CFLAGS}/" Makefile.orig > Makefile
+ -system-libmng -system-libpng -gif -platform linux-g++ \
+ -ldl -lpthread -no-g++-exceptions
+
cd ${S}
- try make symlinks src-moc src-mt sub-src sub-tools
+ try make SYSCONF_CFLAGS=\"$CFLAGS\" SYSCONF_CXXFLAGS=\"$CXXFLAGS\" \
+ symlinks src-moc src-mt sub-src sub-tools
+
+ # leave out src-tools for testing !
}
src_install() {